PfSense vs Huawei E3131 3g modem



  • I tried plugging a Huawei E3131 modem into my pfSense 2.0.2 box and …

    FreeBSD/i386 (pfSense.localdomain) (ttyv0)

    *** Wecome to pfSense 2.0.2-RELEASE-pfSense (i386) on pfSense ***

    WAN (wan)                ->ed0        -> xxx.xxx.xx.xxx (DHCP)
      LAN (lan)                ->fxp0        -> 192.168.1.1

    1. Logout (SSH only)                8) Shell
    2. Assign Interfaces                9) pfTop
    3. Set Interface(s) IP address      10) Filter Logs
    4. Reset webConfigurator password  11) Restart webConfigurator
    5. Reset to factory defaults        12) pfSense Developer Shell
    6. Reboot system                    13) Upgrade from console
    7. Halt system                      14) Enable Secure Shell (sshd)
    8. Ping host

    Enter an option:

    and I get;

    ugen0.2: <huawei>at usbus0
    umass0: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus0
    umass0:  SCSI over bulk-Only; quirks = 0x0000
    umass0:2:0👎 Attached to scbus2
    umass1: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus0
    umass1:  SCSI over bulk-Only; quirks = 0x0000
    cd1 at umass-sim0 bus 0 scbus2 target 0 lun 0
    cd1: <huawei mass="" storage="" 2.31="">Removable CD-ROM SCSI-2 device
    cd1: 1.000MB/s transfers
    cd1: cd present [65536 x 2048 byte records]
    umass1:3:1👎 Attached t scbus3
    (probe0:umass-sim1:1:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
    (probe0:umass-sim1:1:0:0): CAM status: SCSI Status Error
    (probe0:umass-sim1:1:0:0): SCSI status: Check Condition
    (probe0:umass-sim1:1:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
    da1 at umass-sim1 bus 1 scbus3 target 0 lun 0
    da1: <huawei sd="" storage="" 2.31="">Removable Direct Access SCSI-2 device
    da1: 1.000MB/s transfers
    da1: Attempt to query device size failed: NOT READY, medium not present

    tried typing
    usb_modeswitch
    at the prompt
    zilch

    so how do I get it to work …  ???</huawei></huawei></huawei></huawei></huawei>


  • Netgate Administrator

    Did you install usb_modeswitch?

    Did you read this: http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=984
    Looks like this appears as a network device by default.

    Steve



  • Hi … the Short version of Greetings & Salutations

    Nope ... it not coming up in pfSenses' list of wan or lan interfaces.

    ... mumble ... frak ... mumble ...

    ... evil modem ...

    ... mumble ... frak ... mumble ...


  • Netgate Administrator

    You will have to modeswitch the modem, using either u3g or usb_modeswitch, and then you will see a new device in /dev. It may be a usb serial device or a usb ethernet device.
    Did you install usb_modeswitch? It's not in pfSense by default.

    Steve



  • I have been beating my head against the wall for hours here, can anyone give me any directions on how to install usb_modeswitch on pfsense 2.0.2 amd64 bit edition


  • Netgate Administrator

    There's some instructions here:
    http://forum.pfsense.org/index.php/topic,46329.msg247933.html#msg247933
    They are for i386 so you'll have to substitute amd64.

    Steve


Log in to reply