Transparent NTP Redirection



  • I found this cool trick to redirect all NTP on your network to pfsense:

    http://www.interspective.net/2012/07/pfsense-ntp-and-network-sneakery.html

    However since 2.0.2 (I think), the loopback adapter is no longer available to select for listening.  Is this something that can be fixed?  I've read the NTP daemon was switch in 2.0.2.



  • Perhaps I found my own answer - in the NTP logs I see this:

    Feb 28 14:52:03 ntpd[36694]: Listen normally on 3 lo0 ::1 UDP 123
    Feb 28 14:52:03 ntpd[36694]: Listen normally on 2 lo0 127.0.0.1 UDP 123
    Feb 28 14:52:03 ntpd[36694]: Listen and drop on 1 v6wildcard :: UDP 123
    Feb 28 14:52:03 ntpd[36694]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123

    I'm guessing that even though it doesn't show it, it is always listening on the loopback.


  • Rebel Alliance Developer Netgate

    If you select no interfaces, it binds to all, including localhost.

    The NTP daemon was changed and the two of them had completely different mechanisms for binding/listening.



  • If your clients use DHCP, you can also communicate a specific SHCP server via the "NTP servers" option.

    Of course, this is not as bulletproof as the "sneaky approach". It's also less geeky ;)


Log in to reply