New squid package issue



  • I'm running pfsense 2.0.2-RELEASE.  I attempted to install Squid 3.1.20 pkg 2.0.6 (Squid3).  It will not start and throws the following error in the cache log (/var/log/squid/cache.log):

    2013/03/04 00:08:30| Starting Squid Cache version 3.1.20 for i386-portbld-freebs
    d8.1...
    2013/03/04 00:08:30| Process ID 443
    2013/03/04 00:08:30| With 3463 file descriptors available
    2013/03/04 00:08:30| Initializing IP Cache...
    2013/03/04 00:08:30| DNS Socket created at [::], FD 11
    2013/03/04 00:08:30| DNS Socket created at 0.0.0.0, FD 12
    2013/03/04 00:08:30| Adding domain eruditorum.local from /etc/resolv.conf
    2013/03/04 00:08:30| Adding nameserver 127.0.0.1 from /etc/resolv.conf
    2013/03/04 00:08:30| Adding nameserver ###.###.###.### from /etc/resolv.conf
    2013/03/04 00:08:30| User-Agent logging is disabled.
    2013/03/04 00:08:30| Referer logging is disabled.
    2013/03/04 00:08:30| errorpage.cc(293) errorTryLoadText: '/usr/local/etc/squid/errorpage.css': (13) Permission denied
    2013/03/04 00:08:30| Unlinkd pipe opened on FD 18
    2013/03/04 00:08:30| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
    2013/03/04 00:08:30| Store logging disabled
    2013/03/04 00:08:30| Swap maxSize 0 + 262144 KB, estimated 20164 objects
    2013/03/04 00:08:30| Target number of buckets: 1008
    2013/03/04 00:08:30| Using 8192 Store buckets
    2013/03/04 00:08:30| Max Mem  size: 262144 KB
    2013/03/04 00:08:30| Max Swap size: 0 KB
    2013/03/04 00:08:30| Using Least Load store dir selection
    2013/03/04 00:08:30| chdir: /var/squid/cache: (13) Permission denied
    2013/03/04 00:08:30| Current Directory is /usr/local/www
    2013/03/04 00:08:30| mimeInit: /usr/local/etc/squid/mime.conf: (13) Permission denied
    2013/03/04 00:08:30| helperOpenServers: Starting 5/5 'ssl_crtd' processes
    2013/03/04 00:08:30| Accepting  HTTP connections at [::]:3128, FD 31.
    2013/03/04 00:08:30| HTCP Disabled.
    (ssl_crtd): Uninitialized SSL certificate database directory: /var/squid/lib/ssl_db. To initialize, run "ssl_crtd -c -s /var/squid/lib/ssl_db".
    2013/03/04 00:08:31| Ready to serve requests.
    2013/03/04 00:08:31| WARNING: ssl_crtd #1 (FD 19) exited
    (ssl_crtd): Uninitialized SSL certificate database directory: /var/squid/lib/ssl
    

    I've tried removing and reinstalling the package.  After the removal I manually remove all the other directories and files I could manually identify that were related to Squid.  I also tried to initialize the certificate database directory using the command listed in the log file to resolve the ssl_db error and changing the ownership of /var/squid and /usr/local/etc/squid to to the user "squid" to resolve the permissions errors.

    One question I have is which username should the Squid process be running as ("squid" or "proxy")?  Also, any other suggestions anyone has for getting the package running will be helpful.  I'd also like to install SquidGuard, but until I get this package working I'm holding off.

    Thanks!



  • I get this kind of error too.

    Squid Cache (Version 3.1.20): Terminated abnormally.

    CPU Usage: 0.013 seconds = 0.007 user + 0.007 sys
    ….......................................................
    .013/05/23 08:57:58| chdir: /var/squid/cache: (13) Permission denied
    2013/05/23 08:57:58| Current Directory is /usr/local/www
    2013/05/23 08:57:58| mimeInit: /usr/local/etc/squid/mime.conf: (13) Permission denied
    .....................................
    FATAL: The ssl_crtd helpers are crashing too rapidly, need help!



  • @tzlwin:

    FATAL: The ssl_crtd helpers are crashing too rapidly, need help!

    are you using ssl_crtd  on squid 3.1?  ???

    This feature is implemented on squid3-dev, not 3.1.


Locked