Configuração de redirecionamento de porta para IP



  • Boa Tarde Galera.

    Estou com o seguinte cenário: Tenho duas centrais de cameras com ip finais 150 e 151. Na configuração de ambas está sendo utilizado o no-ip para efetuar o acesso via url. No pfsense, configurei para a porta 3777 ser redirecionada a uma delas, no caso a com ip final 150. Qndo tento acessar via web a camera, recebo a seguinte mensagem: Potential DNS Rebind attack detected, see http://en.wikipedia.org/wiki/DNS_rebinding
    Try accessing the router by IP address instead of by hostname.

    Alguem pode me ajudar? Obrigado.



  • Esqueci de dizer, no browser eu vejo que caio no firewall pois aparece o simbolo do Pfsense e o numero 501.



  • bom dia

    cara, faz o teste, na opção System>Advanced, tem la DNS Rebind Check, marca la para desativar, e testa novamente o acesso.

    provavelmente deve ser isso.

    abraço.



  • @Babingthon:

    bom dia

    cara, faz o teste, na opção System>Advanced, tem la DNS Rebind Check, marca la para desativar, e testa novamente o acesso.

    provavelmente deve ser isso.

    abraço.

    Efetuei essa configuração, só que agora, ao invés do endereco no-ip entrar na minha camera, cai direto no Pfsense. O que devo fazer agora?



  • Efetuei essa configuração, só que agora, ao invés do endereco no-ip entrar na minha camera, cai direto no Pfsense. O que devo fazer agora?

    Uma pergunta básica, você esta colocando a porta 3777 na url quando tenta acessar a camera?
    Geralmente quando vc utiliza ADSL e faz dmz do modem pro ip do pfsense aparece uma msg que se nao me engano é essa ai, basta marcar a opcao "disable_http_referer" em system->advanced.



  • @kelsen:

    Efetuei essa configuração, só que agora, ao invés do endereco no-ip entrar na minha camera, cai direto no Pfsense. O que devo fazer agora?

    Uma pergunta básica, você esta colocando a porta 3777 na url quando tenta acessar a camera?
    Geralmente quando vc utiliza ADSL e faz dmz do modem pro ip do pfsense aparece uma msg que se nao me engano é essa ai, basta marcar a opcao "disable_http_referer" em system->advanced.

    Então. Vou te explicar meu ambiente. Pensando depois, talvez eu nem precise usar o no-ip para acessar remotamente a minha central da camera pois possuo um link dedicado. Sim, eu coloco a porta 3777 na url porém quando eu faço isso, nem carrega, nem entra no pfsense e nem na camera.



  • @kelsen:

    Efetuei essa configuração, só que agora, ao invés do endereco no-ip entrar na minha camera, cai direto no Pfsense. O que devo fazer agora?

    Uma pergunta básica, você esta colocando a porta 3777 na url quando tenta acessar a camera?
    Geralmente quando vc utiliza ADSL e faz dmz do modem pro ip do pfsense aparece uma msg que se nao me engano é essa ai, basta marcar a opcao "disable_http_referer" em system->advanced.

    Coloquei a tela de configuração do sistema de cameras para melhor visualizar.




  • Como você ta fazendo no pfsense ? tire um screenshot da configuração do nat e cole aqui para ver-mos



  • Um screenshot do nat como o Luiz disse pode ajudar, qualquer coisa utilize o tcpdump na interface wan e veja se há o tráfego esperado.



  • @Luiz:

    Como você ta fazendo no pfsense ? tire um screenshot da configuração do nat e cole aqui para ver-mos

    Seque os screens da config do pfsense.

    Obrigado.

    ![Captura de tela 2013-03-06 às 16.32.48.png](/public/imported_attachments/1/Captura de tela 2013-03-06 às 16.32.48.png)
    ![Captura de tela 2013-03-06 às 16.32.48.png_thumb](/public/imported_attachments/1/Captura de tela 2013-03-06 às 16.32.48.png_thumb)
    ![Captura de tela 2013-03-06 às 16.36.47.png](/public/imported_attachments/1/Captura de tela 2013-03-06 às 16.36.47.png)
    ![Captura de tela 2013-03-06 às 16.36.47.png_thumb](/public/imported_attachments/1/Captura de tela 2013-03-06 às 16.36.47.png_thumb)



  • A parte mais importante vc nao colocou, nat reflection ta como default? tem uma regra na interface liberando o tráfego?
    Outros redirecionamentos estão funcionando?
    Utilizou o tcpdump pra ver se o tráfego chega na interface?
    Vá em Diagnostics -> states, veja se há alguma entrada relacionada ao tráfego, se não, vá em status -> system log->firewall e veja se há alguma entrada relacionada ao tráfego.



  • @kelsen:

    A parte mais importante vc nao colocou, nat reflection ta como default? tem uma regra na interface liberando o tráfego?
    Outros redirecionamentos estão funcionando?
    Utilizou o tcpdump pra ver se o tráfego chega na interface?
    Vá em Diagnostics -> states, veja se há alguma entrada relacionada ao tráfego, se não, vá em status -> system log->firewall e veja se há alguma entrada relacionada ao tráfego.

    A parte da imagem que faltava.

    ![Captura de tela 2013-03-06 às 17.45.49.png](/public/imported_attachments/1/Captura de tela 2013-03-06 às 17.45.49.png)
    ![Captura de tela 2013-03-06 às 17.45.49.png_thumb](/public/imported_attachments/1/Captura de tela 2013-03-06 às 17.45.49.png_thumb)



  • @kelsen:

    A parte mais importante vc nao colocou, nat reflection ta como default? tem uma regra na interface liberando o tráfego?
    Outros redirecionamentos estão funcionando?
    Utilizou o tcpdump pra ver se o tráfego chega na interface?
    Vá em Diagnostics -> states, veja se há alguma entrada relacionada ao tráfego, se não, vá em status -> system log->firewall e veja se há alguma entrada relacionada ao tráfego.

    Olhei nos logs e em nenhum dos dois achei nenhuma entrada referindo se ao ip 10.15.10.16.



  • Use o tcpdump na WAN, (aqui no forum tem tutorial) veja se o tráfego chega na interface, muito estranho isso de vc não achar entradas na tabela de estado da conexão ou no log do firewall, isso indica que não há tráfego ou o firewall ta bloqueando e vc não conseguiu ver isso no log.



  • Hmmm… algumas dúvidas a respeito da imagem configuração do sistema de cameras que você colocou acima:

    1- A configuração usa o gateway 10.15.10.254 - que gateway é esse?
    2- Logo mais abaixo, nessa mesma imagem, tem um campo Preferred configurado com IP 10.15.10.253 - quem usa esse IP?

    E quanto a essa questão abaixo que não foi respondida?

    @kelsen:

    Uma pergunta básica, você esta colocando a porta 3777 na url quando tenta acessar a camera?



  • Olhando novamente na configuracao da camera, tu viu la, HTTP port 80? seu pfsense ta usando https? ja tentou fazer um port forward na porta 80 pro ip da camera pra ver se abre alguma coisa?



  • Já desabilitou o web gui redirect rule para não dar conflito com a sua publicação de nat na porta 80?



  • @kelsen:

    Olhando novamente na configuracao da camera, tu viu la, HTTP port 80? seu pfsense ta usando https? ja tentou fazer um port forward na porta 80 pro ip da camera pra ver se abre alguma coisa?

    Reparei isso tambem tenta mudar o http port para uma porta diferente ou a mesma da regra do nat.
    eu fiz um dvr e fiz a liberacao da porta no nat e funcionou normal pelo no-ip.
    A regra esta igual a sua da nat.
    Marquei as opções " Disable DNS Rebinding Checks " e "Disable HTTP_REFERER enforcement check "

    Porem a porta que coloquei na nat é a mesma que o http port. a sua é 3777 coloque 3777 na http port e no link coloca http://nome_no-ip:3777
    :D


Log in to reply