WAN Failover issues with Gateway Monitoring



  • I temporarily flip flopped our Gateway Tiers around (1 and 2) and when I switched them back Tier one will not work unless I disable Gateway Monitoring.  I am monitoring an Alternative Monitor IP (8.8.4.4 Google's DNS).  Under status Gateways everything shows up fine and is in Green but it just doesn't route to it unless I disable the Gateway monitoring.  Any suggestions, KB's, or troubleshooting steps anybody can suggest?  I think I have exhausted google on this topic so I decided to try the forum.



  • Things I have tried:

    Rebooting router
    Creating a new gateway and deleting the old one and adding it to the gateway group
    tweaking packet and latency value thresholds
    pinging monitor IP from WAN interface



  • i think there have been some fixes regarding that in the unreleased 2.0.3 & 2.1 versions.

    you could try either of them to see if the issue's are resolved.



  • @heper:

    i think there have been some fixes regarding that in the unreleased 2.0.3 & 2.1 versions.

    you could try either of them to see if the issue's are resolved.

    I am on the latest stable release which is 2.0.2 which I just updated from 2.0.1 to see if it resolved the issue.  I would prefer to remain on a stable release if I can.  Is there any other troubleshooting steps you could recommend?



  • @heper:

    i think there have been some fixes regarding that in the unreleased 2.0.3 & 2.1 versions.

    you could try either of them to see if the issue's are resolved.

    From what I gather you are referring to this.  http://redmine.pfsense.com/issues/2513  This only seems to be an issue with the route not being removed from the routing table which can be seen under Diagnostics –> Routes when changing a monitor IP.  I went ahead and removed the routes from a SSH shell using route delete confirmed deletion under Diagnotics --> Routes and re-added them using the GUI by adding a Gateway Monitor IP and confirmed under Diagnostic --> Routes that they were there.  From the PFSense node shell I am able to reach addresses as expected using traceroute however clients are still not routed that way.  Can anybody please help?  I currently have Gateway Monitoring disabled however since that ISP is somewhat flakey I want to get it monitoring again.



  • Release 2.0.3 is very stable.  It's waiting for some FreeBSD security changes before it's release.  I've been running it for the past three months without any issues.  I upgraded due to issues in 2.0.2.



  • @tim.mcmanus:

    Release 2.0.3 is very stable.  It's waiting for some FreeBSD security changes before it's release.  I've been running it for the past three months without any issues.  I upgraded due to issues in 2.0.2.

    How do I go about installing 2.0.3?  I can't seem to find a download for it so I can perform a manual firmware update.



  • In this post toward the end I describe how to do the manual update:

    http://forum.pfsense.org/index.php/topic,58933.msg316734.html#msg316734



  • @tim.mcmanus:

    In this post toward the end I describe how to do the manual update:

    http://forum.pfsense.org/index.php/topic,58933.msg316734.html#msg316734

    Thanks Tim.  Got what I needed now to keep my fingers crossed for tomorrow morning to see if I can get this stuff working.



  • Ok I just changed to 2.0.3 this morning and am still having issues with the monitor IP causing traffic to not route through the WAN interface.  Can anybody think of anything else to check to try and troubleshoot this issue?



  • worked with madnote earlier today via commercial support to track down what was happening. In some circumstances where you have a lower-tier gateway with monitoring disabled and a higher tier with it enabled, the online status of the higher tier gateway is ignored. Work around in this circumstance was just enabling monitoring on all the gateways. Proper fix coming in 2.1.
    https://redmine.pfsense.org/issues/2910


Locked