Packets from ProxyArp IPs no longer reaching LAN [Solved]



  • We have a Dual Wan set up, with Virtual IPs (ProxyARP) set up on each of the Wan interfaces.  Recently, I rebooted the machine, which was running 1.2 beta-1, and now the Port Forwardings on the virtual IPs no longer work.  Port forwarding on the interface IP addresses does work.

    The firewall log doesn't show the packets being dropped.  When I run tcpdump to track the packets, I can see them coming in on the Virtual IPs, but I don't see them going out on the LAN interface.

    I have tried restoring the config.xml, reinstalling 1.2 beta-1 and then restoring the config.xml, upgrading to 1.2 rc1, and setting this up on a different machine.  No luck.

    Anyone have any ideas what the problem could be?

    Thanks in advance!

    -Randall



  • I was able to solve this by temporarily assigning the WAN Interface's IP address to each of our other static IP addresses, and then finally back to the original IP address.  Now our Virtual IPs are working again.  I'm guessing there was some ARP-related issue with Verizon's DSL equipment.  I'm not sure I understand why simply using ProxyARP for the Virtual IP addresses did not work.

    Has anyone else experienced this problem?  Well, hopefully this post will help anyone else who has this problem.

    -Randall



  • I also just had the same problem thanks for the tip to fix.

    This seems like it could have something to do with verizon and pfsense as I am also on verizon.



  • I just encountered this same issue with a Verizon business connection (FiOS, not DSL), and found that using CARP instead of ProxyARP also seems to work, without having to cycle your WAN IP.


Locked