LAN names not resolving correctly - ( solved )



  • I have a fresh pfsense box (latest version) setup at a small business I have got everything working nicely except for a few things.

    Whenever I try to access our local server via \server\ it does not work, I am however able to access the files via \192.168.1.19\ or \server.domainname
    The problem is I need to be able to access it via \server\    without the .domainname, under DNS forwarder i have Enable dns forwarder, register DHCP leases in DNS forwarder, register DHCP static mappings in dns forwarder and Resolve to DHCP mapping first all checked, i have played around with these settings and nothing seems to change the way it behaves.

    I have nothing statically mapped and I have everything using a dhcp range of 192.168.1.20 - 192.168.1.150 for the lan. I have a 3rd opt nic card installed with a wifi AP installed that is working correctly, but i have it currently disabled until I get this problem resolved.

    Please help me I need to get this up asap, thanks in advance for your help :)

    Version 2.0.2-RELEASE (amd64)
    built on Fri Dec 7 22:39:16 EST 2012
    FreeBSD 8.1-RELEASE-p13

    You are on the latest version.
    Platform pfSense
    CPU Type Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz
    Current: 300 MHz, Max: 1800 MHz



  • Sounds like you're not using the local DNS server.  Since this is a small business… I'll assume they're running AD?  You need to configure DHCP to hand out your internal DNS server to your clients.

    The DNS forwarder just forwards requests up to the ISP.


  • LAYER 8 Global Moderator

    And if you want to resolve a netbios name like server, I would suggest you have that box answer netbios broadcasts.  Or run wins

    Are they computers on the same network segment?  The just enable broadcast to resolve such names.

    If you want to be able to resolve a name via just using host, then correctly setup your search domains to match up, etc.



  • For this setup I am not using AD, it is less then 20 employees. I am a little confused with this, if I am not using the local DNs server then where is the option to set it to use the local dns server, for my DNS servers on my main page I have the first one as 127.0.0.1 the second one is opendns of 208.67.222.222, I also have Allow DNS server list to be overridden by DHCP/PPP on wan. What else am I missing? Thanks for your help so far.


  • LAYER 8 Global Moderator

    Does not matter if your using dns to be honest \servername is a netbios name..  sure your windows computer will ask dns for it, by tacking on its dns..

    You can verify this with simple sniff of the traffic.

    So look at my attached, I did a net view for \servername

    This is a madeup name not going to resolve on my network, but look what happens.  My box 192.168.1.100 asks its dns (pfsense) 192.168.1.253 for servername**.local.lan**

    Because .local.lan is this computers primary domain, and therefore in the searchlist, if I just use a hostname its going to tack that right on the end there.  So you see the dns query for servername.local.lan, pfsense says sorry does not exist.

    Now look what happens - my computer starts broadcasting like crazy asking for servername via broadcast to 192.168.1.255, now if there was servername box - he should of responded. and there you go name resolution and can access said server.

    Now I have my node type set to broadcast, because I am not running wins so hybrid or directed makes no sense.  But hybrid would broadcast as well.  Now you run into a problem if the name your going to broadcast for is on a different segment.  If so setup a wins server.  Or correctly use dns, ie your hosts should have a FQDN!!  name**.domain.tld**

    All your computers should use the same, and that is what they should use as their search list when they query your dns.

    Your domain should be handed out in your dhcp settings and this should be what your boxes use when they register names via dhcp, etc.




  • Thank you for the detailed reply johnpoz, it was very useful. I did however fix the problem. Or found a work around as I had to get this up in anyway possible for business to run securely. I added the server to the DHCP static mapping on my lan interface, then under DNS forwarding I made sure that "Register DHCP static mappings in DNS forwarder" was checked. After that I went around to all the computers did a ipconfig /release and /flushdns /renew and I was then able to \server\ and get to the resources. My new problem is that as new devices are added to the network my DHCP is assigning them to the wrong interface ip range. But nevertheless it is working, the end users are happy. next weekend when I go back I will try to clean it up a bit. I will start a new thread for new problem :) thanks a ton for help was much needed. :)


  • LAYER 8 Global Moderator

    What I don't understand is why your not finding the \server via broadcast no matter what your dns was.  Is this server on a a different network segment?

    What node type to you have set on the clients?  Have you configured the server not to answer broadcast netbios queries?  Do you have a firewall running on it?  Do you not have netbios over tcp enabled?  If your all on the same network and you share something in the windows world you should be able to just broadcast for the netbios name.



  • After adding the the server to its own DHCP static ip range, All I did was, 1. flushdns on all computers 2. renew ip on all computers 3. cleared states on pfsense firewall. I was then able to see the server \server . This is a fresh install of the firewall, so it was all default settings. Only thing I changed was I added a opt1 nic card for the wifi AP and then bridged that to the lan network. I am still having issues the users are reporting that wifi is connecting but for some reason only certian devices are allowed to see the internet, laptops can see internet but ipod/ipad and droid devices cannot.


Log in to reply