Pfsense 2.1 PS3 and Netflix



  • Ok after days of reading and trying different things I still have no luck.  Here's what's going on. Netflix on my PS3 is not working it will load a movie up  (The red bar fills all the way up) but doesn't load anything.

    UPnP & NAT-PMP is enabled.

    Under NAT Manual Outbound NAT rule generation (AON - Advanced Outbound NAT) Enabled.

    I tried turning off HAVP… No Luck.

    This only happens on the PS3. Netflix plays on my NeoTV and Computers just fine. So I figured its something to do with the PS3 and a setting I have wrong somewhere.

    Any help or point in the right direction would be Great!

    Thank You



  • Hello there!

    have you found a fix for this?
    if so could you plz post what you did to make it work?
    i am having the same issue whit my LG tv, loads up the red bar to full/100% and then nothing happen's.

    -Thanks



  • Yes I figured out my problem.  Squid was blocking me. I went into Proxy Server > General Settings  scroll down until you see  "Bypass proxy for these source IP's" and add your PS3's IP address there. You can add more than 1 IP. Soon as I did that it took off working.

    I did Static my PS3 machines and started UPnP & NAT-PMP then added each PS3 into the "User Specified Permissions"

    Then in Added them into the Firewall.

    I gave them Static IP's to allow ONLY them to bypass things. In my setup in pfSense I used the /32 to make sure and not the /24. Example 10.10.10.10/32

    I really didn't care if the PS3's bypassed everything it's the Computers I'm worried about that's WHY I Static my PS3's.

    I always Static everything I have Control over it better. I'm not a Big DHCP fan, but I do use it for Wireless, BUT I MAC address all my Wireless anyway so nobody gets in.



  • I haven't had problem with PS3/netflix and the 2.1 beta with Squid, transparent proxy.
    Works well.



  • @Rickinfl:

    Yes I figured out my problem.  Squid was blocking me. I went into Proxy Server > General Settings  scroll down until you see  "Bypass proxy for these source IP's" and add your PS3's IP address there. You can add more than 1 IP. Soon as I did that it took off working.

    I did Static my PS3 machines and started UPnP & NAT-PMP then added each PS3 into the "User Specified Permissions"

    Then in Added them into the Firewall.

    I gave them Static IP's to allow ONLY them to bypass things. In my setup in pfSense I used the /32 to make sure and not the /24. Example 10.10.10.10/32

    I really didn't care if the PS3's bypassed everything it's the Computers I'm worried about that's WHY I Static my PS3's.

    I always Static everything I have Control over it better. I'm not a Big DHCP fan, but I do use it for Wireless, BUT I MAC address all my Wireless anyway so nobody gets in.

    Sweet i'll give that a go an see if it will work for my TV (Don't have ps3) :( anywho i am running 2.0.2 and happen to see this post on google so i will post back if it fix the issue or not.



  • So i got it to work and idk if this is a good/right way to do it but all i did was go to " Services >> Proxy server: General settings " and ticked Transparent proxy "If transparent mode is enabled, all requests for destination port 80 will be forwarded to the proxy server without any additional configuration necessary." & added the ip address of my tv but as i was testing i got it to work with out no ip address in the box.

    So idk if this way is the right way to fix this issue but it works.


Log in to reply