Enabling Serial in WebGui. -Screen turns to gibberish *Using correct settings*



  • Hey guys,

    I ran the Live CD installer on my workstation and installed PF-Sense to an IDE drive.

    After installing, I popped the drive out, installed it into my Firebox X700 and powered it on.

    At this point, my firebox was connected to my old laptop via serial with Putty running.

    When the box booted, everything was perfect, I manually mounted the drive (because the installation was performed on different hardware) and got to configuring.

    Here is the problem, when I went into the WebGUI, I enabled both SSH and Serial connectivity… And THAT has broken my serial connection.

    Now when I boot the box, all of the text is gibberish, I've changed the baud, bit parity, etc. I don't have access to the web-gui anymore because I did a factory default after screwing something up, but my terminal is still all Gibberish!! Any ideas??

    I know that I can ultimately re-install PFSense onto the drive, but I'm trying to learn this environment.

    Thanks for all of your help!



  • Problem resolved. That's strange, after enabling SERIAL access in the web_gui, I could no longer use 9600 baud, I had to change PUTTY to use a throughput of 115200.

    Good to know, this might be very common knowledge to most of you. But all of the technical documents that I have read so far concerning serial says 9600 baud.

    EDIT

    Neither Enabling or Disabling console access in the Web_Gui provides you with access to the CLI menu.

    AFTER enabling serial console access, you must change the baud speed from 9600 to 115600 in order for the screen to print correctly.

    IF you leave serial console access unchecked, set your baud-speed to 9600 in order for the screen to print correctly.

    Nevertheless, enabled or disabled, you can't drop into the CLI menu via serial. At least I can't.

    I'll do some research.


  • Netgate Administrator

    Did you do anything else to effect the serial baud rate manually? Like this:
    http://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#Serial_Port_Quirk

    Is this with 2.0.2?

    I believe this to be problem only with the firebox X-Core, some hardware incompatibility.

    Steve



  • Hey Steve!

    I made no manual changes to the baud rating. Literally, I installed PFsense, loaded up the web_gui, and have only enabled disabled the serial console from that menu.

    I wish I could get the blasted serial console to work though, (in the event I fubar something). I hate popping this IDE drive out every-time I screw something up! LoL!

    EDIT Sorry, I forgot to mention, this is V2.02

    Interestingly enough, I no longer have to kill/reinitialize the web-configurator (lighttpd) every 5 minutes when it becomes unresponsive now that I'm running a full-on install. That's a plus!


Log in to reply