WAN Connectivity Lost After IPv6 DHCP Renew



  • Scenario:

    • Running Native Dual-Stack IPv6 with PD
    • There was an IPv6 DHCP renewal and a WAN IPv6 address change
    • IPv6 continued to work, however IPv4 traffic could not pass after rc.newwanipv6 ran. 
        (Not a typo, IPv6 worked, IPv4 was dead).
    • The IPv4 address was still assigned, but no connectivity.

    Attempt to recover:

    • Since the Snort service was stopped and would not restart, I reinstalled the package …. no change.
    • I did a full system reboot .... no change (IPv6 worked, IPv4 did not).
    • I upgraded to the latest nightly ( Thu Mar 7) ... everything this is working normally.

    Version where problem occurred:

    2.1-BETA1 (amd64)
    built on Sun Mar 3 03:14:49 EST 2013
    FreeBSD 8.3-RELEASE-p6

    Relevant Logs:

    23:00:30 dhcpd: Information-request message from fe80::226:bbff:fe72:48e6 port 546
    23:00:30 dhcpd: Sending Reply to fe80::226:bbff:fe72:48e6 port 546

    23:00:46 php: : rc.newwanipv6: Informational is starting re1.
    23:00:51 php: : rc.newwanipv6: on (IP address: 2001:558:xxxx:xxxx:79d0:5e47:xxxx:4105)

    23:00:53 php: : ROUTING: setting default route to 68.32.172.1
    23:00:53 php: : ROUTING: setting IPv6 default route to fe80::201:5cff:fe24:9301%re1

    23:00:54 check_reload_status: Reloading filter
    23:00:54 apinger: Starting Alarm Pinger, apinger(30263)
    23:00:54 apinger: bind socket: Can't assign requested address

    23:01:00 php: : pfSense package system has detected an ip change 2001:558:xxxx:xxxx:4569:fde3:xxxx:565c ->  2001:558:xxxx:xxxx:79d0:5e47:xxxx:4105 … Restarting packages.

    23:01:03 apinger: Exiting on signal 15.
    23:01:03 php: : Restarting/Starting all packages.

    23:01:04 check_reload_status: Reloading filter

    23:01:18 snort[45041]: *** Caught Term-Signal
    23:01:19 php: : The command '/usr/local/etc/rc.d/snort.sh stop' returned exit code '1', the output was ''
    23:01:22 snort[77775]: FATAL ERROR: pf.conf => Table snort2c don't exists in packet filter: No such file or directory

    Other threads about WAN DHCP issues:

    Since a few day's losing the wan (dhcp) ip address
    http://forum.pfsense.org/index.php/topic,58819.0.html

    WAN link does not recovering automatically after ISP connection restored
    http://forum.pfsense.org/index.php/topic,53221.0.html



  • Saw that as well when the following topic happened to me.

    http://forum.pfsense.org/index.php/topic,59876.0.html

    There's a workaround in that thread.


Log in to reply