Nat SQL



  • Boa noite, a um tempo atrás tinha feito um NAT das portas 1433 e 1434 para um SQL Server.
    Atualizei a versão do pfsense e tive alguns problemas com DNS, então resolvi reinstalar a versão 2.0.1 e voltar o backup, acontece que agora o NAT não funciona mais, a regra de nat está igual, mais creio que teve algo que alterei e não consigo achar o que.
    segue minha regra nat:

    WAN1 TCP * * WAN1 address 1433 192.168.0.4 *
    WAN1 TCP * * WAN1 address 1434 192.168.0.4 *

    onde 192.168.0.4 é meu servidor SQL.
    Alguém sabe algum teste que posso fazer?
    Fiz um teste no site http://ping.eu/port-chk/ e vi que a porta 1433 e 1434 está closed.



  • Buenas!

    • Aparentemente está faltando você dizer em que porta do seu host 0.4 os pacotes devem ser direcionados;

    • Veja se as tuas regras de NAT são "reflexivas" (geraram rules na WAN);

    • Evite fazer este tipo de NAT. É absolutamente inseguro abrir na web, sem tunelamento e criptografia, um server de banco de dados.

    Abraços!
    Jack



  • modifiquei a regra para e nada.
    WAN1 TCP/UDP * * WAN1 address 1433 192.168.0.4 1433

    Sim são reflexivas, geram rules na WAN.
    Preciso fazer esse teste e funcionar por enquanto, até que seja implantado uma vpn, que seria o caso para proteger né?



  • @madrugaaa:

    modifiquei a regra para e nada.
    WAN1 TCP/UDP * * WAN1 address 1433 192.168.0.4 1433

    Veja se não é o firewall do server Windows bloqueando as conexões. Veja também se o teu SQL Server está configurado para aceitar conexões de fora do localhost (ele mesmo).

    Preciso fazer esse teste e funcionar por enquanto, até que seja implantado uma vpn, que seria o caso para proteger né?

    Exato…



  • Jack obrigado pela atenção.
    No Windows Server e no SQL está tudo ok, pois fiz um teste jogando esse servidor em outro link, fiz o nat no modem e deu tudo OK.
    O problema é o firewall que está bloqueando mesmo.



  • Verifique o seu nat e monitore via tcpdump se o pacote está chegando na wan e depois se está saindo da lan para o servidor e com que ip.

    Verifique também o gateway do seu servidor mysql e também se não existe alguma regra na wan "atrapalhando" seu nat.

    att,
    Marcello Coutinho


Log in to reply