Problema com portas do webconfigurator com Squidguard + WPAD



  • Bom dia!  :D
    Sou novo no forum e na jornada PFsense. Aprendi bastante com forum e blog da comunidade.
    Mas chegou um ponto que tive que abrir um post com um problema e duvida em relação que esta acontecendo comigo.
    Procurei e não achei nada a respeito até o momento.  :-[

    Seguinte quando configuro uma porta por Ex. "8180" no campo "TCP Port" da aba SYSTEM > Advanced no webconfigurator tanto http ou https
    Influencia no squidguard na mensagem de erro interno.
    Fica carregando e depois aparece a mensagem que a pagina nao pode ser exibida.
    Porem fui em Service > Proxy Filter > Log > Filter config e percebi que nao altera o codigo a porta fica a porta 80. Isso é normal ou eu to fazendo besteira?
    Bom esse é algo que nao consegui resolver.

    Outro problema é com WPAD que se eu deixar em https o protocolo no webconfigurator ele nao funciona o WPAD. apenas se deixar http e na porta padrao.
    Quando digito por http://192.168.1.1/wpad.dat ele joga para https://192.168.1.1/wpad.dat e aparece a mensagem que o certificado nao é confiavel. ae se clico para continuar ele aparece o script no navegador.

    Entao o que estou fazendo de errado?
    segue as imagens em anexo.
    Segui os tutorias do forum mesmo, para configurar. Testei tanto como modo transparente e manual. Com e sem Loadbalance.















  • @djblade:

    Entao o que estou fazendo de errado?

    djblade, Bem vindo ao fórum! :)

    O melhor a fazer neste caso é subir um http para o wpad e a pagina de erro do squidguard.

    Você pode passar o pfsense para https e subir outro lighthttp na 80 para servir somente estes dois arquivos.



  • @marcelloc:

    O melhor a fazer neste caso é subir um http para o wpad e a pagina de erro do squidguard.

    Você pode passar o pfsense para https e subir outro lighthttp na 80 para servir somente estes dois arquivos.

    Olá Marcelloc, obrigado pelo retorno, agora minha duvida é em subir outro lighthttp pelo que sei é o proprio pfsense que já tem um servidor web que chama de "lighthttp" certo? no caso onde foi que joguei os arquivos do wpad em "/usr/local/www" .

    Como aponto para esses arquivos quando é realizada a requisição pelo navegador ?



  • Boa tarde.
    Você ira ter problemas se utilizar em hospedar o wpad no pfsense com algumas versões no navegador IE caso você tiver a GUI rodando sobre https.
    O unico navegador que funciona com a GUI rodando sobre https e o mozilla firefox o chrome e o IE não comporta bem.
    Segue a sugestão do Marcelloc.
    Configure um apache e jogue o wpad nele.
    Obs. para o wpad funfar as estações de sua rede deveram saber resolver o dominio tambem.
    Se você for em uma estação e digitar ping wpad e o mesmo resolver então seu wpad ira funcionar.



  • Boa noite!

    Obrigado pela orientaçao Gilmar, bom pelo menos sei que não fiz nada de errado com emu PFsense.
    Bom vou realizar os testes e ver como funciona.

    Obrigado a todos! ;D



  • Fala pessoal, travei denovo aqui com wpad.
    Acredito que o problema esta via DNS.
    Assim, no IE e Chrome funciona. No firefox nao.
    Sendo que se eu coloco IP fixo no computador, não funciona mais o wpad. Entao eu deduzi que quando o PC pega um ip atribuido pelo PFsense funciona o Wpad, que no caso esta funciona via DHCP.

    Digitando http://wpad/wpad.dat nao baixa pelo FF ou quando esta com IP fixo no computador.

    Tambem nao pinga wpad .

    o que estou fazendo de errado o que estou deixando passar?

    No caso estou fazendo sem o windows server. Isso influencia em alguma coisa?



  • Fala pessoal!
    Bom pelo que pesquisei, e logicamente sem um servidor de DNS nao funcionaria via DNS. Tentei ate fazer o proprio PF como servidor de DNS usando um package que tem disponivel da versao do tinydns porem nao obtive sucesso. Bom enfim voltei com W2008 na rede fiz a entrada de DNS e nao funcionou.
    Dei uma olhada na configuracao das zonas e nao tinha zona reversa configurada. Apos configurar a Zona reversa funcionou no FF via WPAD e com IP fixo.
    como suspeitava era realmente algo sobre configuracao.
    Porem o estranho que se eu pingar WPAD pela estacao, nao encontra. Ainda acho que esta faltando alguma coisa.
    Mas aparentemente parece estar funcionando.

    Se alguem tiver alguma sugestao, é bem vinda…  ;D



  • @djblade:

    Porem o estranho que se eu pingar WPAD pela estacao, nao encontra. Ainda acho que esta faltando alguma coisa.

    A requisição que a estação faz é wpad.seu.dominio.

    Alguns posts atras, você tentava resolver wpad sem domínio algum.



  • @marcelloc:

    @djblade:

    Porem o estranho que se eu pingar WPAD pela estacao, nao encontra. Ainda acho que esta faltando alguma coisa.

    A requisição que a estação faz é wpad.seu.dominio.

    Alguns posts atras, você tentava resolver wpad sem domínio algum.

    Marcelo, to ralando aqui para aprender.

    Quando vc fala que posts atras nao coloquei wpad.meu_dominio.com que no caso utilizei para teste teste.com
    seria wpad.teste.com é isso?

    Assim, ainda continua.. quando coloco IP fixo na estacao nao funciona no chrome e firefox, porem funcionou pelo IE.
    Eu digito no navegador no IE "http://wpad.teste.com/wpad.dat" ou "http://192.168.0.1/wpad.dat" ele exibe o script no navegador.
    Se eu digito "http://wpad/wpad.dat" ele pede para fazer download.

    Quando tiro o IP fixo funciona nos 3 navegadores. To ficando louco já.
    No servidor 2008 esta com ip fixo e funciona normalmente.

    Quando eu realizo o comando "ping wpad" do servidor 2008 funciona mas na estacao nao funciona.
    Quando digito o comando "ping wpad.teste.com" funciona normalmente tanto no servidor como na estacao.

    A configuracao do Wpad alem se se orientar pelos topicos presentes aqui no forum
    Segui esse tutorial
    http://blogdonerd.com.br/2011/10/descoberta-automatica-de-proxy-wpad-web-proxy-auto-discovery/

    IP do PFsense: 192.168.0.1

    Enfim segue as configuracoes logo abaixo. Talvez voces conseguem ver algo que estou errando talvez.

    Em System > General Setup

    Hostname: fw
    Domain: teste.com

    DNS Servers: 192.168.0.1
        8.8.8.8
        8.8.4.4

    Marcado opcao "Allow DNS server list to be overridden by DHCP/PPP on WAN"

    Em DHCP Server

    Additional BOOTP/DHCP Options

    Number: 252
    Type: Text
    Value: http://192.168.0.1/wpad.dat

    Em DNS forwarder

    Marcado "Enable DNS forwarder"

    em host overrides

    Host: wpad
    Domain: teste.com
    IP address: 192.168.0.1

    Windows 2008

    Criei uma entrada Host (A)

    Host: wpad
    FQDN: wpad.nome_dominio.local
    Endereço IP: 192.168.0.1

    Obrigado pela paciencia e ajuda.  ;D



  • Ainda nao consegui fazer funcionar com IP fixo.
    Utilizei o comando "nslookup wpad" verifiquei que aparece diferente quando se utiliza IP fixo e Ip dinamico.

    Com ip dinamico aparece assim:

    Servidor: fw.teste.com
    Address: 192.168.0.1

    nome = wpad.teste.com
    address: 192.168.0.1

    E com ip fixo aparece assim:

    Servidor: fw.teste.com
    Address: 192.168.0.1

    nome = wpad
    address: 192.168.0.1

    Entao acho que o problema esta ai. mas nao sei agora onde concerto isso. Pelo que vi é o nome que especifico no DNS forwarder.  :'(



  • Boa tarde pessoal!

    Bom apos mais alguns testes, (talvez eu tenha comido bola) mas o seguinte os teste que fiz era realizado em Grupo de trabalho ao inves de ingressado a um dominio. Apos ingressar no dominio pingou "WPAD". e Funcionou normalmente nos 3 navegadores que estava testando.
    No resultado do comando nslookup apareceu igual aparecia no w2008 com excessao que aparece a mensagem "Não é resposta de autorizacao"
    Isso nao parece normal correto?
    Porem nao apresentou problemas ate o certo momento.

    Ai pergunto, o wpad nao funciona com grupo de trabalho via DNS? apenas funciona ingressado ao um dominio?


Log in to reply