Unknown dhcp option value 0xc8



  • Hello everyone! I'm new on pfsense and linux and i'm trying to configure an internet server with dual-WAN. I have 3 network interfaces, rl0 (connects through pppoe via bridged modem), rl1 (connects through dhcp via bridged modem) and dc0 (i have dhcp server running on lan 192.168.0.x)

    My problem is that the rl1 interface (called OPT1) is getting an IP from my ISP via DHCP, but the gateway goes down 5 seconds later after "getting" an IP and i cannot ping anything. I said "getting" cause i always seem to get the same ip. I tried connecting my netbook running windows xp sp3 and i recieve always a different ip and i can navigate, ping, etc.

    The thing is, i looked in the system log and i saw this:

    dhclient: PREINIT
    Mar 14 11:30:28 dhclient[38073]: DHCPREQUEST on rl1 to 255.255.255.255 port 67
    Mar 14 11:30:29 dhclient[38073]: DHCPACK from 201.213.176.1
    Mar 14 11:30:29 dhclient[38073]: unknown dhcp option value 0xc8
    Mar 14 11:30:29 dhclient[38073]: unknown dhcp option value 0xc8
    Mar 14 11:30:29 dhclient: REBOOT
    Mar 14 11:30:29 dhclient: Starting add_new_address()
    Mar 14 11:30:29 dhclient: ifconfig rl1 inet 181.x.x.213 netmask 255.255.255.0 broadcast 255.255.255.255
    Mar 14 11:30:29 dhclient: New IP Address (rl1): 181.x.x.213
    Mar 14 11:30:29 dhclient: New Subnet Mask (rl1): 255.255.255.0
    Mar 14 11:30:29 dhclient: New Broadcast Address (rl1): 255.255.255.255
    Mar 14 11:30:29 dhclient: New Routers (rl1): 181.x.x.1
    Mar 14 11:30:29 dhclient: Adding new routes to interface: rl1
    Mar 14 11:30:29 dhclient: Creating resolv.conf
    Mar 14 11:30:29 check_reload_status: rc.newwanip starting rl1
    Mar 14 11:30:29 dhclient[38073]: bound to 181.x.x.213 – renewal in 7144 seconds.
    Mar 14 11:30:32 php: : rc.newwanip: Informational is starting rl1.
    Mar 14 11:30:32 php: : rc.newwanip: on (IP address: 181.x.x.213) (interface: opt1) (real interface: rl1).
    Mar 14 11:30:32 apinger: Exiting on signal 15.

    I looked for the possible explanation of this but all i understood was that i would need to configure dhcp client to add the... option? that the interface needs to ask to my ISP

    Am i going the right way? What can i do? :S

    Thanks in advance !!



  • Dunno!

    0xc8 = 200 (?)

    According to http://www.iana.org/assignments/bootp-dhcp-parameters/bootp-dhcp-parameters.xml#options option 200 is 'Unassigned'.

    I know various vendors (Cisco I'm talking about you!) like to use 'extra' DHCP/BOOTP options for configuring VoIP phones etc.  Could it be somehting your ISP uses to configure the 'stock' routers for 'normal' users?  Can you run a packet capture and see what the option 0xc8 contains?



  • Thanks for answering!

    I figured it out this morning. It was the modem… The Firewall and WAN blocking was activated, it seems that this only bothered pfsense. When it wanted to check the gateway via ping, it was blocked so ping was'n giving anything back and pfsense assumed that it was offline. Now i can ping everywhere and i am navigating :D

    I have doubts about that option 200 though... how could i run a packet capture to see what's in it?



  • @pilgrim87:

    how could i run a packet capture to see what's in it?

    Diagnostics / Packet capture
    Set 'interface' to the appropriate entry

    The resulting .cap file can be analysed quite nicely with Wireshark


Log in to reply