Problema com Varnish



  • Bom dia a todos do Forum.

    Estou com um problema no Varnish e gostaria de saber se alguem pode me ajudar.

    Configurei o Varnish para acessar dois sites diferente, um de uma aplicação que temos aqui na empresa e o outro pro webmail.
    Até ai tudo bem, tudo está funcionando, o problema é que o Android não consegue fazer o Sync das mensagens do servidor webmail, pelo que parece, ele utiliza a porta 80 para fazer esse sincronismo, e não sei porque ele não identifica o caminho depois do site (ex: www.site.com.br/pasta/arquivo).
    Existe alguma coisa que de para fazer? Esse autosync não tem a opção de alterar a porta de sincronismo.
    Nos dispositivos da apple, o sync funciona bem, só com Android que tem esse problema.

    Desde já agradeço.



  • schimmelpfeng, bem vindo ao fórum! :)

    Você já tentou acessar a url que o android está chamando para ver se o varnish está encaminhando para o servidor correto?

    para ver o log do varnish, recomendo você dar uma boa olhada no site deles, uma vez que para aumentar a performance, o log fica todo em memoria. Você precisa executar um comando para ler isso e mostrar em forma de log.

    Nos logs do servidor web aparece a requisição feita pelo android?

    att,
    Marcello Coutinho



  • Obrigado pela resposta Marcelo.

    O android está direcionado para o link certo sim.
    Não sei o que pode ser.
    Apenas o sync http do android que não funciona, mas se abro um navegador no Android, ele direciona normalmente para o site.



  • Ninguém poderia me ajudar?


Locked