Dynamic DNS errors, doesn't auto update



  • 2.1-BETA1 (i386)
    built on Thu Mar 14 23:00:40 EDT 2013
    FreeBSD router.myownname.com 8.3-RELEASE-p6 FreeBSD 8.3-RELEASE-p6 #1: Thu Mar 14 23:28:26 EDT 2013 root@snapshots-8_3-i386.builders.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8 i386

    **It seems like there are errors in the auto update for the two dynamic dns services I use.

    One is dyndns and the other one is namecheap.com for my own domain name.
    I'm using MLPPP with two DSL modems if that matters.

    I believe this taken from the system logs shows when it is trying to update, but never does.**

    _Mar 16 11:22:18 php: : Curl error occurred: Couldn't bind to ''
    Mar 16 11:22:18 php: : DynDNS (myownname.dyndns.org): Current Service: dyndns
    Mar 16 11:22:18 php: : DynDNS (myownname.dyndns.org): DynDns _checkStatus() starting.
    Mar 16 11:22:18 php: : DynDNS (myownname.dyndns.org): DynDns _update() starting.
    Mar 16 11:22:18 php: : DynDns debug information (myownname.dyndns.org): DynDns: More than 25 days. Updating. 1363458138 - 1355989139 > 2160000
    Mar 16 11:22:18 php: : DynDns (myownname.dyndns.org): Current WAN IP: 173.244.101.15 Cached IP: 173.244.108.55
    Mar 16 11:22:18 php: : DynDns debug information (myownname.dyndns.org): 173.244.101.15 extracted from local system.
    Mar 16 11:22:18 php: : DynDNS (myownname.dyndns.org): running get_failover_interface for . found
    Mar 16 11:22:18 php: : DynDns debug information (myownname.dyndns.org): 173.244.101.15 extracted from local system.
    Mar 16 11:22:18 php: : DynDns: updatedns() starting
    Mar 16 11:22:17 php: : Curl error occurred: Couldn't bind to ''
    Mar 16 11:22:17 php: : DynDNS (home.myownname.com): Current Service: namecheap
    Mar 16 11:22:17 php: : DynDNS (home.myownname.com): DynDns _checkStatus() starting.
    Mar 16 11:22:17 php: : Namecheap (home.myownname.com): DNS update() starting.
    Mar 16 11:22:17 php: : DynDNS (home.myownname.com): DynDns update() starting.
    Mar 16 11:22:17 php: : DynDns debug information (home.myownname.com): DynDns: More than 25 days. Updating. 1363458137 - 1355989137 > 2160000
    Mar 16 11:22:17 php: : DynDns (home.myownname.com): Current WAN IP: 173.244.101.15 Cached IP: 173.244.108.55
    Mar 16 11:22:17 php: : DynDns debug information (home.myownname.com): 173.244.101.15 extracted from local system.
    Mar 16 11:22:17 php: : DynDNS (home.myownname.com): running get_failover_interface for . found
    Mar 16 11:22:17 php: : DynDns debug information (home.myownname.com): 173.244.101.15 extracted from local system.
    Mar 16 11:22:17 php: : DynDns: updatedns() starting
    Mar 16 11:22:14 check_reload_status: Reloading filter

    This is after I did a forced update on bother services.
    I can go to each service in the DynDns tab and perform a save/force update, both always work.

    _Mar 16 11:37:22 php: /services_dyndns_edit.php: phpDynDNS (myownname.dyndns.org): (Success) IP Address Changed Successfully! (173.244.101.15)
    Mar 16 11:37:22 php: /services_dyndns_edit.php: phpDynDNS: updating cache file /conf/dyndns_wandyndns'myownname.dyndns.org'1.cache: 173.244.101.15
    Mar 16 11:37:22 php: /services_dyndns_edit.php: DynDns debug information (myownname.dyndns.org): 173.244.101.15 extracted from local system.
    Mar 16 11:37:22 php: /services_dyndns_edit.php: DynDNS (myownname.dyndns.org): Current Service: dyndns
    Mar 16 11:37:22 php: /services_dyndns_edit.php: DynDNS (myownname.dyndns.org): DynDns _checkStatus() starting.
    Mar 16 11:37:21 php: /services_dyndns_edit.php: DynDNS (myownname.dyndns.org): DynDns _update() starting.
    Mar 16 11:37:21 php: /services_dyndns_edit.php: DynDns debug information (myownname.dyndns.org): 173.244.101.15 extracted from local system.
    Mar 16 11:37:21 php: /services_dyndns_edit.php: DynDns: updatedns() starting
    Mar 16 11:37:17 php: /services_dyndns_edit.php: phpDynDNS: (Success) IP Address Updated Successfully!
    Mar 16 11:37:17 php: /services_dyndns_edit.php: phpDynDNS: updating cache file /conf/dyndns_wannamecheap'home.myownname.com'0.cache: 173.244.101.15
    Mar 16 11:37:17 php: /services_dyndns_edit.php: DynDns debug information (home.myownname.com): 173.244.101.15 extracted from local system.
    Mar 16 11:37:17 php: /services_dyndns_edit.php: DynDNS (home.myownname.com): Current Service: namecheap
    Mar 16 11:37:17 php: /services_dyndns_edit.php: DynDNS (home.myownname.com): DynDns _checkStatus() starting.
    Mar 16 11:37:16 php: /services_dyndns_edit.php: Namecheap (home.myownname.com): DNS update() starting.
    Mar 16 11:37:16 php: /services_dyndns_edit.php: DynDNS (home.myownname.com): DynDns update() starting.
    Mar 16 11:37:16 php: /services_dyndns_edit.php: DynDns debug information (home.myownname.com): 173.244.101.15 extracted from local system.
    Mar 16 11:37:16 php: /services_dyndns_edit.php: DynDns: updatedns() starting
    Mar 16 11:37:16 check_reload_status: Syncing firewall

    Any ideas on where to look to fix this? This error for me has always existed, on all beta and none beta builds.



  • How can I make it update more often?
    I see this entry in the system log a lot., sometimes every 5 minutes.

    php: : phpDynDNS: No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.



  • It only routinely updates with the dynamic DNS provider if the IP address has changed or 25 days have passed since the last update. (Most dynamic DNS providers don't want you updating your records all the time with the same IP address) To force an update, edit the Dynamic DNS entry and press "Save & Force Update".
    PS: I have no idea what the curl error is - sorry!



  • Is there a setting anywhere that I can change the value from 25 days to something like 7 days?
    Dyndns.org sends me an email if my pfsense pc hasn't sent up an update in 30 days, which sometimes happens.



  • The code is currently locked to 25 days. But it does keep files /cf/conf/dyndns* that remember the latest updated value and the date/time it was updated. So it should happily force an update after 25 days, if your dynamic IP has not changed itself in that time.
    You can also edit the Dynamic DNS entry and press "Save & Force Update".



  • I too am having this problem. I use NameCheap and have been using them for sometime while using untangle as my firewall. I never had any problem before as far as getting NameCheap's Dynamic Dns to retrieve my IP address automatically from my untangle box. I see that my IP address is cached in green but when I look at NameCheap I noticed that my host IP was still the default 127.0.0.1. Any idea to why this is happening? could this be tied to squid or snort?  ??? ???



  • What does the system log show for the dynamic dns entry results?

    Can you show a screen capture of the dynamic dns config page for us to see?



  • Is there a way to see how the watchdog checks if my ip changed?
    I'd like to see which IP address he's checking. My PFsense is behind my ADSL modem so the ip address of my pfsense/WAN will always remain the same. The IP Address of my ADSLmodem/WAN will change.



  • You want to put your ADSL modem into transparent bridge mode.



  • @gavit:

    Is there a way to see how the watchdog checks if my ip changed?
    I'd like to see which IP address he's checking. My PFsense is behind my ADSL modem so the ip address of my pfsense/WAN will always remain the same. The IP Address of my ADSLmodem/WAN will change.

    The pfSense software uses http://checkip.dyndns.org/ to find the current public IP of the WAN. That will return the public IP that your front-end ADSL router/modem has, and then pfSense will update the dynamic DNS name to point to that public IP. I do this lots from pfSense with a private WAN IP behind an ADSL router, it works fine.
    Of course, if you actually want to provide some service to outside users using that dynamic DNS name, then you will also have to port forward the relevant port(s) on the ADSL router through to your pfSense.


Log in to reply