Network Booting using CentOS 6.3 as PXE file server



  • Hi there,

    I am confused as to how to go about wanting to get my install of pfsense working so that it can allow for installing Linux (namely Centos 6.3) on new machines without having to use the DVD drive.

    I am unable for some reason to use the DVD drive for installing a clean copy of CentOS 6.3 on  it, I  have a spare computer I can put CentOS on to allow it to download the  image from.

    I am just really confused about the settings where it says:

    Enter the root-path-string

    Then a dialogue box with the following below it:

    Note: string-format: iscsi:(servername):(protocol):(port):(LUN):targetname

    I really don't have a clue what  I am putting in the latter, I have put the IP address of my server I want to use as my next-server (which is where the boot image resides isn't it? with the file pxelinux.0 but the rest I am confused about the one  below that.

    Any help's much appreciated,
    Jeremy.



  • Been doing a bit of reading from this tutorial:
    http://lsgondane.hubpages.com/hub/How-to-Configure-PXE-Server-on-Linux

    Though it TFTP (which is obviously going to my file server where the CentOS images are located) and keeps saying can't find config files.

    I know the configs I have set in pfsense are working, just can't seem to understand why it can't find the config files under /tftpboot/pxelinux.cnf/default

    I mean this is the contents of that file:

    default: off

    description: The tftp server serves files using the trivial file transfer \

    protocol.  The tftp protocol is often used to boot diskless \

    workstations, download configuration files to network-aware printers, \

    and to start the installation process for some operating systems.

    service tftp
    {
    socket_type = dgram
    protocol = udp
    wait = yes
    user = root
    server = /usr/sbin/in.tftpd

    server_args = -s /var/lib/tftpboot # there's nodirectory there or file so!

    http://lsgondane.hubpages.com/hub/How-to-Configure-PXE-Server-on-Linux says:

    server_args = -s /tftpboot

    disable the yes command here:

    disable = yes

    above url says no:

    disable = no
    per_source = 11
    cps = 100 2
    flags = IPv4
    }


Log in to reply