Limiter cannot handle high speed - can you reproduce?



  • Hello

    There seem to be an issue with the limiter. It works great from 1Mbitps and up til about 17Mbit. When raising the limiter to higher speeds the throughput will not raise but stay on the same 17-18Mbit… even if limiter is set as high as 50Mbit

    Before raising a bug I would like a little feedback from all you pf users. Is it a known issue? Does any of you have limiters running with higher speeds than 20Mbit?

    Setup:
    lim_lan_in = 40Mbit (various speeds from 1Mbit to 50Mbits)
    lim_lan_out = 40Mbit (various speeds from 1Mbit to 50Mbits)

    LAN rule - for alias (with just a single test PC)
    add advanced IN = upload limiter, OUT = download limiter

    BR. Anders

    UPDATE:
    Should have added 2.0.2 and quadcore 2,6GHz embedded system with flash storage
    Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz
    Up to 10% CPU when under high load



  • Have you tried 2.1? I don't use limiter, but I do use traffic shaping and it works up to 250MBits/sec (my max at the moment). Right now I am capping my 250MBits/sec connection at 100Mbits/sec with a burst up to 200Mbits/sec for 60 seconds.



  • Hi

    No, I have not tried the 2.1. It is a router in production so I would stick to the stable release.

    Would you please check this feature on 2.1? It is simple to to and and remove afterwards.

    Create to limiter (to limiters to maintain full duplex):
    a) lan_in = 100Mbit
    b) lan_out = 100Mbit
    Go to you firewall rules for LAN.
    Edit defalt allow any (or add new rule just for your computer right before default rule)
    Scroll to the bottom to advanced features
    Add your limiters to the rule

    Reste states or reboot router

    Do a speed test from you computer….
    I really do wonder what your result will be.

    To remove limiter again just edit your rule and remove it from in/out where you just added it.



  • I cannot on that connection. I actually use 2.1 in production, so resetting states or rebooting is not an option. If you have ESX you can test VM -> pfsenseVM -> VM using iperf.



  • Ok. No worries. Thanks anyway ;-)





  • I have not made it work but core team suggested that my limiter probably was inside another pipe. And therefore did not have all bandwith available. It makes sense.



  • I have reopenen the bug. I cannot get a throughput of more than 15Mbipts in a limiter. As suggested I have increased "Queue size" under advanced. But when doing this I break the limiter somehox and it stop beeing updated.



  • Well, I have experimented in the limiter on 2.1rc1 and I am able to limit my inbound all the way to my max at 50Mbits/s (at the office). I don't have a 2.0.3 that I am willing to test with ATM.



  • Ok, thanks.
    What hardware do you use for router? And where did you buy?



  • I tested it on a HP DL380 G3 server (x32 install). I bought it from a local guy. I don't think the issue is hardware. If you can reach 50+ MBits without the limiter and are only hitting 10% usage at 15Mbits, then you should have enough horsepower for a 50Mbit/s connection. Somewhere in the neighborhood of 40% CPU for 50Mbits or so.



  • No, probably not. I got dubplex 200Mbitps. Max load is typically 180Mbitps in and 70Mbitps out. Single users can go up to 85Mbitps on there 100Mbit ports. CPU typically 5% max 10%

    But when adding a limiter speed drops to about 15Mbitps for the user I apply the limiter to…

    Just read these two post today. Aparently there is something wrong with the limiter config.
    http://forum.pfsense.org/index.php/topic,65145.0.html (error when using queue size)
    http://forum.pfsense.org/index.php/topic,62938.0.html (not all limiters show on limiter info)

    Now I just have to buy some paid support so I can learn what to do about it.
    https://portal.pfsense.org/



  • @Tillebeck

    are there any news on that issue ? did you get an solution ?

    greetings



  • No, unfortunately. I have given up using limiters on this particular production router.

    I just bought some new routers and want to set one up with 2.1 and test that to see if issue with limiters has been solved in 2.1.