[Resolvido] SQUID NÃO STARTA



  • Bom dia!!

    O SQUID estava funcionando normal, hoje de manhã ele parou, não incia de jeito nenhum.
    Já removi o pacate e reinstalei, reiniciei o pfsense e nada. Quando clico em start ele fica uns segundos depois volta pra stop.
    Alguém pode me ajudar por favor?

    https://lh4.googleusercontent.com/-v12XMZgDVYI/UUcdZFx_sPI/AAAAAAAACyM/RjBlIeBqeq8/s384/squid.jpg



  • Olá,

    Conecte-se ao PFSense usando o WinSCP e verifiche o arquivo Cache.log em /var/squid/ e tente localizar o motivo do erro.

    Pode ser problema com espaço em disco ou o cache pode conter arquivos truncados ou danificados.



  • só fica aparecendo essa mensagens:

    apinger: Erro ao alimentar rrdtool: Broken pipe
    18 março 00:07:51 php: / status_services.php: O comando "/ usr / local / etc / rc.d / squid.sh stop 'código de saída retornado '1', a saída foi" squid: ERROR: Não foi possível enviar o sinal de 15 a processo 35537: (3) Não tal processo "
    18 março 00:07:53 squid [720]: Squid Parent: processo filho começou 965
    18 março 00:07:53 squid [720]: Squid Parent: processo filho saiu 965 devido ao sinal de 6
    18 março 00:07:53 kernel: pid 965 (lula), uid 62: saiu em sinal de 6
    18 março 12:07:56 squid [720]: Squid Parent: processo filho começou 1438
    18 março 00:07:57 squid [720]: Squid Parent: processo filho saiu 1438 devido ao sinal de 6
    18 março 00:07:57 kernel: pid 1438 (squid), uid 62: saiu em sinal de 6
    18 março 00:08:00 squid [720]: Squid Parent: processo filho começou 2508
    18 março 00:08:00 squid [720]: Squid Parent: processo filho saiu 2508 devido ao sinal de 6
    18 março 00:08:00 kernel: pid 2508 (squid), uid 62: saiu em sinal de 6
    18 março 12:08:03 squid [720]: Squid Parent: processo filho começou 9718
    18 março 12:08:03 squid [720]: Squid Parent: processo filho saiu 9718 devido ao sinal de 6
    18 março 12:08:03 kernel: pid 9718 (squid), uid 62: saiu em sinal de 6
    18 março 12:08:06 squid [720]: Squid Parent: processo filho 10.275 começou
    18 março 12:08:06 squid [720]: Squid Parent: processo filho 10275 saiu devido ao sinal de 6
    18 março 12:08:06 kernel: pid 10275 (squid), uid 62: saiu em sinal de 6
    18 março 12:08:06 squid [720]: Saindo devido a repetidas, freqüentes fracassos
    18 março 00:08:21 php: / status_services.php: O comando "/ usr / local / etc / rc.d / squid.sh stop 'código de saída retornado '1', a saída foi" squid: ERROR: Não foi possível enviar o sinal de 15 a processo 10275: (3) Não tal p



  • Qual sua versão do PFSense?

    Tente limpar o cache do Squid:

    
    /usr/local/etc/rc.d/squid.sh stop
    rm -rf /var/squid/cache/
    mkdir -p /var/squid/cache/
    chown squid:squid /var/squid/cache/
    chmod 777 /var/squid/cache/
    squid -z
    /usr/local/etc/rc.d/squid.sh start
    
    


  • 2.0.2



  • Deu certo amigo !1 muito obrigado!!! tenha um bom dia!!



  • Opa ;D

    Edite o Tópico e coloque [RESOLVIDO]  ;)



  • Como colocou seu log em português?



  • da forma que esta ali, deve ser tradução do google.



  • @kelsen:

    da forma que esta ali, deve ser tradução do google.

    Ainda sim esquisito. tem linhas que não estão totalmente traduzidas.
    apinger: Erro ao alimentar rrdtool: Broken pipe



  • squid: ERROR: Não foi possível enviar o sinal de 15 a processo 35537: (3) Não tal processo "

    Pela tradução, parece algo feito a mão tb, hauahua
    só o Blad Runner pra explicar tal fato!


Log in to reply