Host override



  • Hi,

    I'm kind of stuck with the DNS forwarder right now. I'd like it to serve a particular IP when my clients resolve some particular domain, which seems to be the point of the "host override" section in services\dns forwarder. Unfortunately pfsense doesn't seem to use the entries that i've put there. If I make an entry "www.google.com = 1.1.1.1, a nslookup on google.com on a client machine would still give me a "real" google ip, obtained from pfsense.
    What have I misunderstood?

    Thank you


  • LAYER 8 Global Moderator

    does you client have the query cached, did you apply the settings on pfsense?  Are you sure your asking psfsense for dns?

    D:\Dropbox\tools\bin>dig @192.168.1.253 www.google.com

    ; <<>> DiG 9.9.2-P1 <<>> @192.168.1.253 www.google.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17696
    ;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.google.com.                        IN      A

    ;; ANSWER SECTION:
    www.google.com.        1      IN      A      1.1.1.1

    ;; Query time: 234 msec
    ;; SERVER: 192.168.1.253#53(192.168.1.253)
    ;; WHEN: Tue Mar 19 10:41:49 2013
    ;; MSG SIZE  rcvd: 48

    So you can see - pfsense responded with what I put in the host override for www.google.com




  • OK, thanks to your answer now I get it! I made an error in the "host" part –- oops

    Again, thank you sir!


Log in to reply