LAGG Interface not showing on VLAN Configuration via WebGUI



  • Hi,

    I'm having trouble setting up vlans on LAGG interfaces via webGUI. After creating LAGG interface, it doesn't appear on menu list on Vlan Configuration page (interfaces_vlan_edit.php). These are my two interfaces and lagg0 created:

    $ ifconfig lagg0
    lagg0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=4019b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,vlan_hwtso>ether a0:36:9f:18:06:de
    inet6 fe80::a236:9fff:fe18:6de%lagg0 prefixlen 64 scopeid 0xf
    nd6 options=43 <performnud,accept_rtadv>media: Ethernet autoselect
    status: active
    laggproto fec
    laggport: em5 flags=4 <active>laggport: em3 flags=0<>

    $ ifconfig em3
    em3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=4019b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,vlan_hwtso>ether a0:36:9f:18:06:de
    inet6 fe80::a236:9fff:fe18:6de%em3 prefixlen 64 scopeid 0x5
    nd6 options=43 <performnud,accept_rtadv>media: Ethernet autoselect
    status: no carrier

    $ ifconfig em5
    em5: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=4019b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,vlan_hwtso>ether a0:36:9f:18:06:de
    inet6 fe80::a236:9fff:fe18:8fac%em5 prefixlen 64 scopeid 0x7
    nd6 options=43 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active

    Hardware involved: Intel(R) PRO/1000 Network Connection 7.3.2

    As far as I know, having VLAN_MTU is enough for setting up vlans on LAGG interfaces, but I don't understand why it's not there.

    pfSense 2.0.2 amd64 version:
    FreeBSD net-fw-12.localdomain 8.1-RELEASE-p13 FreeBSD 8.1-RELEASE-p13 #0: Fri Dec  7 23:04:01 EST 2012    root@snapshots-8_1-amd64.builders.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8  amd64

    I think it's a similar bug from this issue closed:
    http://redmine.pfsense.org/issues/948</full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,vlan_hwtso></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,vlan_hwtso></up,broadcast,running,simplex,multicast></active></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,vlan_hwtso></up,broadcast,running,simplex,multicast>


Log in to reply