[SOLVED] Snort and Snort-dev uninstall



  • Hello to all,
    I've been struggling all day with this problem with no avail.
    I've installed snort recently and today appeared an update to the package.
    When I tried to update the package it just hanged up in the "loading package instructions" message. Then snort disappeared from the installed packages list.
    I tried to install it again and it hanged in the same part "loading package instruction".
    I've tried installing the snort-dev package with the same results.

    Does someone knows how to fix this problem? long time ago I found in this forum that editing a configuration file you can "force" the reinstallation of the package, but I can't remember how.

    Thank you for your time and help.

    Edit: I saw the error - Parse error: syntax error, unexpected T_FUNCTION in /usr/local/pkg/snort/snort.inc on line 183

    Edit2: I fixed it. I deleted the /usr/local/pkg/snort folder and then edited the /cf/config.xml to remove all the snort packages references and then I deleted the snort and snort-dev package from the installed packages menu.


Locked