How to get Dyn DNS of pfsense running



  • How guys…please tell me how to i get Dyn DNS service of pfsense running ?

    i tried many times but just i reboot my gateway pfsense can't update my ip(Dyn.com) .

    thank you .



  • I went to the services menu and picked Dynamic DNS then clicked the plus button to add my information. What I have filled in/selected:

    Service Type: DynDNS (dynamic)
    Interface to monitor: WAN
    Hostname: (your Dyn assigned hostname, something like me.dyndns.info)
    Username: (the username and password from Dyn that you set up for your account)
    Password:

    Putting that in and hitting the save button got it working for me.

    You did see the note there and take one of the options?

    Note:
    You must configure a DNS server in System: General setup or allow the DNS server list to be overridden by DHCP/PPP on WAN for dynamic DNS updates to work.

    If that doesn't work then you might need to look at the logs (Status : System Logs : System) for entries from the DynDNS updater to see what is wrong. Posting a snip of any errors here if you need help should get somebody with more experience to chip in.

    Look for something like this at the time you made your edits:  (xxx's to hide my real IP)

    Mar 22 19:29:41 	php: /services_dyndns_edit.php: phpDynDNS: No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Mar 22 19:29:41 	php: /services_dyndns_edit.php: DynDns: Current WAN IP: 68.3.239.xxx Cached IP: 68.3.239.xxx
    Mar 22 19:29:41 	php: /services_dyndns_edit.php: DynDns debug information: 68.3.239.xxx extracted from local system.
    Mar 22 19:29:41 	php: /services_dyndns_edit.php: DynDns: updatedns() starting
    


  • Hi…did you restart your router or modem or gateway ? after that my problem starts up.



  • Post your Dynamic DNS settings (don't tell us your username/password - you will have to get that correct yourself ;) and DynDNS syslog entries - then we can try and help.
    I use the DynDNS service from many sites and it updates fine.



  • These are my settings :

    Service type : DynDNS (dynamic)

    interface : WAN

    Hostname : myDomain

    MX : empty

    Wildcards : unchecked

    username : myusername

    passwd : mypasswd



  • Hostname : myDomain

    In Hostname you have to put the complete domain name that you have registered with DynDNS - e.g. davis-server.dyndns-ip.com



  • @phil.davis:

    Hostname : myDomain

    In Hostname you have to put the complete domain name that you have registered with DynDNS - e.g. davis-server.dyndns-ip.com

    Yes i did that…but also no luck.



  • Hi…my problem that pfsense box updates my domain slowly (about 15 minuts) , can i set time to update that domain ?


Locked