Problemas com Varnish



  • Ola,

    Estou com problemas de publicação do varnish, tenho diversas URLs apontadas para servidores da rede interna, o problema esta nos serviços autenticados (sharepoint por exemplo), quando a primeira pessoa acessa via internet tudo bem, abre a tela de login e o processo flui normalmente, o problema é quando a próxima pessoa tenta acessar, ele já vem com a pagina AUTENTICADA ! ou seja, assim que ele entra com a URL em casa a pagina do Sharepoint (ou de outros serviços) já entra sem pedir login e senha, e o pior, entra com a autenticação da ultima pessoa ! Se reinicio o serviço do varnish ele "apaga" o login anterior… ou seja, o problema parece estar no varnish mesmo... Alguem já passou por isso ou sabe o que pode ser ?

    Outro problema é no caso de LB, se publico 2 servidores internos com a mesma URL, quando acessamos de fora, logamos, porem no meio da navegação ele volta para a tela de login (aparentemente ele esta "trocando" de servidor no meio da navegação)...

    Estou gostando da solução (usava TMG), mas estes detalhes estão causando enormes transtornos...

    Abraços



  • Confere as opções de cache, você deve preservar o cookie para não ter estes problemas de cache com usuários.

    Client identity method : ip address Don't cache posts: marcado
    Session Cache: per user
    Cache static content: when possible



  • Ola !

    Fiz a modificação nesta opções, porem ele continua com o mesmo problema, acabei de fazer um acesso de casa e o IE não pediu a senha (e já entrou logado com o nome de outra pessoa…), o interessante é que tentei acesso pelo Chrome, e ele pede a senha logo de cara (como deveria ser para todos..), coisa doida ..rs

    Abraços

    Alexandre



  • Sabe se a aplicação tem o controle de sessão diferente de JSESSION ou PHPSESSID?


Locked