Open-VM-Tools package not working: "Unsupported file layout"



  • Hello!

    Since a few versions of pfSense 2.1, the Open VM Tools are no longer working. After installation, I get error messages on the console, for each of the driver files:

    kldload: /usr/local/lib/vmware-tools/modules/drivers/vmmemctl.ko: Unsupported file layout

    I'm using the AMD64 version of pfSense.


  • Rebel Alliance Developer Netgate

    That usually means you have somehow managed to get 64-bit packages installed on i386 pfSense or 32-bit package binaries installed on amd64 pfSense. Hard to say how, perhaps you did a firmware upgrade that crossed from one to the other and it didn't remove/reinstall the package binaries. Remove the package entirely (maybe even pkg_delete the bits of it left after removal from the shell) and then install it again.



  • Hello jimp!

    Thanks for your reply and your suggestion!

    Unfortunately, re-installing the package doesn't help, I already tried that several times. I can see that it does download the 64-bit version of the package.

    I never switched firmware between 32 and 64 bit, I always used the 64-bit version of pfSense, at least on the installation in question. The problems DID start though when I did a firmware upgrade.

    I did not find a way to "remove bits of it left" from the shell, what is the package name for "pkg_delete"? The command "pkg_info" only lists "bsdinstaller", "gettext" and "libiconv", nothing of the packages I have installed from the GUI (which is Open-VM-Tools, Zabbix Agent 2 and OpenVPN Client Export Utility).


  • Rebel Alliance Developer Netgate

    Try "pbi_info"

    Then you can remove with pbi_delete



  • Yay, that worked! :)

    You were right. pbi_info showed two versions of the open-vm-tools package, the 64-bit I installed via the GUI, and the 32-bit one I have no idea where it came from.

    I deleted the 32-bit one via pbi_delete and reinstalled the 64-bit from the GUI; all is well. Service is running, kernel modules are loaded, vSphere Client shows tools as running in the VM.

    Thanks a bunch!


Locked