Skype Issue's



  • Hello,

    I'm pretty new to pfsense and well whenever I use skype, I can hear the other person fine, but they constantly complain about me breaking in and out and the call drops quite frequently…

    my hardware is Jetway JC200S-B-JNF99FL-525 2 x 204Pin Intel GMA 3150 Black Mini / Booksize Barebone System
    OCZ Onyx Series OCZSSD2-1ONX32G 2.5" 32GB SATA II MLC Internal Solid State Drive (SSD)
    Kingston 4GB 204-Pin DDR3 SO-DIMM DDR3 1066 (PC3 8500) Laptop Memory Model KVR1066D3S7/4G

    I allowed UPNP in the services, but still no improvement. Skype worked perfectly when I was using my netgear e3000.


  • Netgate Administrator

    I use Skype almost everyday (since my sister moved to the US) and have no problems other than Skype's usual variability.  ;)
    I had trouble narrowing down any recommended settings. I'm sure a large proportion of people here must use it but no one had any advise last time I asked.
    Anyway, Skype is a peer to peer protocol it works best when both ends of the connection are publicly addressable. For that reason if you want to get good quality video calls you need Skype to be listening on your public IP. To do that you can either forward the incoming port to your internal machine manually or use UPNP to do it for you. I have used both methods successfully.
    If you are using UPNP you need to enable NAT-PMP (ironic since Skype is owned by MS). Here is what my UPNP status looks like when Skype has signed on.

    
    Port 			Protocol 	Internal IP 	Description
    53753 keep state 	udp 		192.168.2.22 	NAT-PMP 53753 udp
    53753 keep state 	tcp 		192.168.2.22 	NAT-PMP 53753 tcp 
    
    

    When you are in a call you can bring up the call technical info window and it should have listed: local:good remote:good.
    If it does not then one side of the conversation is going via a skype node and not directly which is much slower.

    If anyone else has any insight on this I'd love to hear it. Despite my best efforts I often see 'local:bad'  :-\

    Steve


Locked