Arpresolve: can't allocate llinfo for



  • could someone give me some insight as to why my freshly installed pfsense box is constantly losing its WAN connection ?

    when i lose it, the log fills up with this:
    kernel: arpresolve: can't allocate llinfo for   <ip redacted="">if i
    A) restart the machine, all is well again, or
    B) go to the WAN interface and make no changes; just click save, and then APPLY, the wan comes right back up

    im on pfSense version 2.0.2, 64bit

    my setup is fairly vanilla; nothing special
    WAN info is handed to pfsense via DHCP; my ISP is comcast

    i have seen multiple threads on the issue but none of them have come to a conclusion.</ip>



  • could this have anything to do with the DHCP lease expiring / renewing from my ISP ?



  • "arpresolve: can't allocate llinfo" means the system is trying to ARP an IP that's not on a locally-connected network. If your WAN loses link for instance, that'll happen. Short of seeing the system logs all around that it's impossible to say what the cause might be in this instance.



  • which system log should i post here to help narrow down the issue ?



  • i may have solved this; im not sure why this works.

    i changed the gateways monitor IP (system –> routing) from my cable modems gateway, to opendns, and sofar it hasn't gone offline...



  • while the arpresilv issue seems to have completley disappeared with the previously mentioned solution, i notive today my log is jam-packed with this message now:

    "dnsmasq[47679]: failed to send packet: Host is down"

    nothing is down that i can see.



  • bump.



  • It may have to do with your WAN IP address changing.

    I experienced the same scenario:  WAN gateway goes down (for whatever reason) and it never reestablishes the connection or renews the DHCP lease.  In the 2-3 times it happened, my ISP, Optimum, was doing residential upgrades and my IP address and gateway addresses changed significantly.  Over the course of 2-3 weekends my residential WAN would fail, but the business WAN stayed up.  So pfSense failed over elegantly, but the residential WAN never came back up until I forced a RENEW from the UI.

    At the time I assumed it was failing because it couldn't ping/find the gateway IP anymore, so I moved the monitor to 8.8.8.8, something far away that wouldn't change.  I also assumed that by virtue of doing that, the gateway ping would force a renew on the WAN.  Since it hasn't happened again, I assumed that worked.

    But I do think there's something wonky going on with DHCP WAN links and pfSense's ability to renew the DHCP address/lease on its own.



  • thanks for sharing your similar experience with me Tim, it sounds almost exactly like my problem; changing the monitor IP worked for me as well; but i wish i could actually understand the root of the problem. ill dig around a bit more but if i don't find anything i wont worry so much as its basically resolved.


Log in to reply