VirtualIP, DHCP client and gateway monitoring not working



  • Hello,

    I have a pfsense box in multi WAN configuration.
    When I set a WAN interface as DHCP client and set on it an IP alias (VirtualIP), it happens that gateway monitoring stops working.
    Not sure if it is because of my misconfiguration or a (known?) bug.
    Please, can anyboby help?

    Here is my configuration.
    One of the WAN i/f (opt1) is attached to a WIFI AP acting as client/bridge vs. other WIFI Hotspot (which provides internet connection).
    Opt1 is configured to get IP address via DHCP.
    The gateway associated to opt1 is 'dynamic' and monitoring is enabled.
    I configured a VirtualIP on opt1 as 'IP alias' and added relevant NAT rule. This to reach the WIFI AP web interface.

    LAN <–-> LAN _ pfSense box _ OPT1 <---> WIFI AP <--z--> WIFI hotspot
    

    IP parameters are:
    LAN: 192.168.35.0/24
    OPT1: DHCP
    OPT1: IP Alias 192.168.34.1/24
    WIFI AP: 192.168.34.230/24
    NAT rule:```
    Interface  Source          Source Port  Destination      Destination Port  NAT Address    NAT Port  Static Port  Description
    WIFI      192.168.35.0/24  *            192.168.34.0/24  *                192.168.34.1    *        NO          Rule for WIFI AP

    OPT1 to WIFI AP connection is wired.
    WIFI AP to WIFI hotspot connection is wireless.
    WIFI AP acts as bridge between wired and wireless sides.
    
    OPT1 gets its ip address via DHCP from WIFI hotspot when WIFI AP is associated with it.
    When the whole chain is up, OPT1 gets all the IP parameters from DHCP **but** gateway monitoring reports the associated gateway as **Offline**.
    
    Relevant /tmp/apinger.status line is:
    

    192.168.43.1|192.168.34.1|WIFI|324|0|0|0.000ms|100.0%|down

    192.168.43.1 is the WIFI hotspot gateway IP addr.
    
    opt1 (if)config is:
    

    re2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=389b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast,wol_mcast,wol_magic>ether 4c:02:89:0a:32:e4
    inet6 fe80::4e02:89ff:fe0a:32e4%re2 prefixlen 64 scopeid 0x3
    inet 192.168.34.1 netmask 0xffffff00 broadcast 192.168.34.255
    inet 192.168.43.216 netmask 0xffffff00 broadcast 192.168.43.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active</full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,simplex,multicast>

    
    Thanks,
    Marco


  • Forgot to mention, pfSense version is 2.0.2-RELEASE.

    Marco


Log in to reply