Lightsquid - Error (1): Cannot get data. Server answered: HTTP/1.0 403 Forbidden



  • Hi,

    When I go to Lightsquid - Proxy State I get an error saying:

    Error (1): Cannot get data. Server answered: HTTP/1.0 403 Forbidden

    Can some please tell me what the problem might be? Thanks



  • When you go to Lightsqid you get 403, I would think the package is not installed properly. Did you try uninstall that package and reinstall?



  • Hi,

    Yes I have re-installed pfSense dozens of time but no luck.

    I have looked around the forum and found out that no one has ever come up with a solution for this problem. I have asked it again to raise attention on this but it seems that no one knows the right answer :(



  • @mat1_8:

    Hi,

    Yes I have re-installed pfSense dozens of time but no luck.

    I have looked around the forum and found out that no one has ever come up with a solution for this problem. I have asked it again to raise attention on this but it seems that no one knows the right answer :(

    I have installed pfsense 2.0.3 with lightsquid
    I still get the same error:

    Error(1): Cannot get data. Server answered: HTTP/1.0 403 Forbidden.

    I think there's no solution yet.



  • I tried reinstalling lightsquid many times. But no luck. I believe configuration is also good.



  • This is an outstanding bug for a long time:

    http://redmine.pfsense.org/issues/2903



  • In the passed, when I got this error, it was because lightsquid adds a remote access subnet for all the subnets you included in the Proxy interface you selected in the general setup.

    If you installed squid, then installed lightsquid, then changed your selected proxy interface at the top of squid general setup then when you go to the Access control page you will probably notice that all of the subnets that would be covered by the interfaces you selected in general setup are not accounted for in the :
    External Cache-Managers list.

    If the External Cache-Managers field does not include 127.0.0.1 plus each subnet that corresponds to EACH LAN, OPT, WAN ect interface you selected in the general setup of squid, don't worry.  Although you can't add to the field manually without causing an error most  likely, you can select the interfaces you want by clicking them (or control + click) if you want more than one.  Then apply your squid settings.  (Don't select all the interfaces + loopback.  It causes error).

    Basically squid has to be fully set up and the lightsquid intalled AND squid proxy interfaces NOT later modified.
    After you apply squid settings, click the reinstall package button next to lightsquid in package manager.

    Unless you have really broken something, it should be working after u select refresh now and then full refresh in lightsquid.

    Worked for me anyway.

    P.S.  I also have all of the subnets I want to allow for TRANSPARENT squid listed in access control > Allowed subnets



  • hi..
    i followed it and its working fine at squid 3.3.5

    http://forum.pfsense.org/index.php?topic=65102.0