Widescreen package in 2.1 breaks



  • Was really pleased to see the widescreen package back in the packages list so I installed it straight away.

    I've just upgraded to the latest snapshot, rebooted, and I would normally expect to see an unrelated error in the 'notification' area on the dashboard. Now, the notification area is yellow, but no text appears in it, so I can't clear the error.

    Do the errors appear elsewhere in the menu system?

    I guess the actual errors no longer align with the notification box so I can't see/clear them. :(

    Any thoughts are gratefully appreciated.

    Simonb


  • Rebel Alliance Developer Netgate

    Widescreen shouldn't have shown up, it's disabled on 2.1 and nobody has fixed it that I've seen. Not sure why it started showing up, but I'll make sure it is disabled again.



  • Thanks - It's gone again. I uninstall it to be safe!



  • @jimp:

    Widescreen shouldn't have shown up, it's disabled on 2.1 and nobody has fixed it that I've seen. Not sure why it started showing up, but I'll make sure it is disabled again.

    Bummer, I had widescreen working fine on 2.0.2….  it was a great looking dashboard.
    Now with 2.0.3 I went to add the widget for Service Status and I get the screen loaded and arranged but when I save it, it shows 3 instances of the newly added widget.  I've seen this before so normally I uninstall widescreen get the dashboard fixed and then reinstall widescreen and all is well.  Now, even without widescreen, 2.0.3 wants to save 3 instances of whatever widget I add.  Kill everything back to what I originally had and all is well....  but now there is no option to reinstall widescreen.  Any Ideas?  Tried 3 different browsers and 2 different systems.  System seems to be working fine, just looks like crap.

    Rick


  • Rebel Alliance Developer Netgate

    Widescreen breaks 2.0.2 and 2.0.3, due to menu overwrites and other issues. It breaks access to NTP (OpenNTP is not on 2.0.2 or 2.0.3) among other things.

    Without a current package maintainer willing to work on it, it may just disappear entirely.



  • @jimp:

    Without a current package maintainer willing to work on it, it may just disappear entirely.

    Jim, Understood.  Don't like it but understood.

    Any advice on how to get 2.0.3 to stop saving 3 instances of services?  If I install and have one working instance of Services, when I save it saves 3, two of which have no properties icon (wrench).  If I delete one and save the dash, it deletes all 3 when I save.

    Rick


  • Rebel Alliance Developer Netgate

    Manually edit config.xml to remove the bad widget entries, or remove the widgets section entirely to start fresh.



  • @jimp:

    Widescreen breaks 2.0.2 and 2.0.3, due to menu overwrites and other issues. It breaks access to NTP (OpenNTP is not on 2.0.2 or 2.0.3) among other things.

    Without a current package maintainer willing to work on it, it may just disappear entirely.

    I guess it did disappear … no longer available in 2.0.3  ???


  • Rebel Alliance Developer Netgate

    It broken the menu on 2.0.2 and 2.0.3, it made it impossible to reach the actual NTP entry in the menu, so it was locked down to 2.0.1.



  • ok … i was wandering where the Status NTP was ... until I removed WideScreen  ;D



  • While widescreen is an awesome pkg it does brake a lot on the menu :(
    Maybe a bounty can motivate a developer to fix it :)



  • @jimp:

    Manually edit config.xml to remove the bad widget entries, or remove the widgets section entirely to start fresh.

    Jim, thanks.  Just got back to this this morning.  I've tried editing with no luck.  Same behavior.  Since loosing widescreen  :'(, if I add "Services Status" I get a single instance, fully functional.  If I select "save settings" I get two more instances, both missing the tool icon in the upper right.  If I delete any one of the three (regardless of how I position them) the first/top one disappears.  When I "save settings" the other two disappear.  I've tried the edit, no joy.

    Exactly which file/area do I change to "remove the widgets section entirely"?

    Thanks,
    Rick



  • Jim,
    N/M…  I found an odd character at the end of the widgets field in the xml file.  Deleted it, restored the file and its all well now.  Remnant of Widescreen?

    Thanks,
    Rick


Log in to reply