[Resolvido] Acesso NO-IP externo funciona! mais interno não!



  • Pessoal,
    fiquei dias, pesquisando sobre isso e não encontrei nenhuma solução para meu problema.

    tenho um servidor com uma aplicação web na porta 8080 rodando dentro da minha rede ip 192.168.0.175, porem tenho que que acessar este servidor utilizando um domínio no-ip, externamente está tudo certo, quem está fora e acessa "endereco.no-ip.biz:8080" consegue, porem se dentro da rede interna utilizar o mesmo endereço "endereco.no-ip.biz:8080" só recebo timeout, assim sou obrigado a acessar pelo ip interno 192.168.0.175:8080.

    o problema é que tenho uma segunda aplicação web que faz um redirecionamento, e não posso utilizar o ip interno. já tentei tudo! DNS forwarder mais não adianta, o que posso fazer?

    tenho acesso externo ao pfsense da empresa, e utilizo o "endereco.no-ip.biz:8989" sendo a porta 8989 do pfsense e acesso normalmente, mais o bendito do servidor na porta 8080 nada!

    pfsense 2.0.2-RELEASE (i386)
    dns google 8.8.8.8 e 8.8.4.4

    desculpa se ficou um pouco confuso, é que a situação é confusa, não existe um termo pra isso pelo menos que eu saiba, e é difícil encontrar alguém aqui no forum com problema parecido.



  • megabasus, bem vindo ao fórum! :)

    habilite o nat reflection na sua regra para resolver seu problema.

    Talvez você vá precisar criar também um outgoing nat para que todos os ips internos acessem o servidor com o ip do firewall, já que a chamada é externa.

    O dns forwarder pode ajudar, mas para tanto você vai precisar usar o dns do pfsense não o do google.

    att,
    Marcello Coutinho



  • Marcelloc,

    Desculpa a demora para responder, foi só habilitar o nat reflection na regra  que libera a porta 8080 e funcionou na hora! :)

    muito obrigado!, espero que isso ajude outros com mesmo problema.

    abraços!



  • Perfeito, me caiu como uma luva.
    Marcelo, mais uma vez obrigado.


Log in to reply