Squid3/Dansguardian not passing traffic



  • I've setup Squid3 as transparent with everything else set to default. I've setup Dansguardian with Shalla's blacklist and blacklisted some categories. When I set the proxy in firefox to 192.168.1.1:8080 to test, nothing gets through (the page times out), as though squid isn't working right maybe.

    I'm running pfsense 2.0 and don't have too much else installed yet. I haven't setup port forwards yet since I'd like to test before I do that. What would be some common causes for a problem like this? What should I look at to troubleshoot?



  • If squid is set as transparent then you just leave the proxy settings blank in the browser. In fact, it will not work (as you see) if you specify the proxy in the browser. So, just clear out the proxy settings in your browsers, and you will be going through the proxy. Try to go to a page that is blocked, to test.

    I haven't used dansguardian, so I am not familiar with it's config, but if you are trying to filter all traffic through both squid and dansguardian, you only set transparent on one of the two, and then have that one(the one with transparent set) forward to the second one (the one without transparent set). However, if dansguardian doesn't work as a cascading proxy then this will not apply.



  • Thanks for the response. I was able to get it working. It was a combination of conflicting squid versions (dansguardian installs squid 2.7 and I had installed squid 3) and I also had to manually set the ip address and port of squid in the Dansguardian config even though I'm only using the defaults. I think it might be a left-over quirk from the multiple squid configuration files causing problems.

    Now, I'm trying to figure out why requests going through Dansguardian/Squid are so slow, but I'll open a new topic for that.


Log in to reply