I have a problem with squid



  • I installed squid and havp
    Both work correctly

    But occasionally squid stops working
    And the only way to restart this installation of all system again
    Removal and installation of squid only not helping

    What could be the problem
    Why is this happening




  • Here are screenshots of the settings

    Even now I have the same problem
    But instead of reinstalling

    I changed havp to transparent instead parent for squid

    So I can browse

    Without it, no Internet access




  • No one is has encountered a problem like this?

    Now in order to have access to the Internet
    Transparent proxy not Checked



  • I suggest posting a screenshot of every configuration page from squid.

    Also, be patient.  Sometimes, it took weeks for someone to reply to my posts, and NO you are not the only one having issues with squid.  Ive had problems since I started using it 3 years ago.  Im still banging my head against the walls as we speak because of this package.

    Post your machine specs and package versions, this can also help others to help you in return.



  • Post is misleading.  You have a problem with squid AND HVAP.
    Suggest disabling/removing hvap and seeing if squid is stable without HVAP.  Then if squid stays up working, you will know a lot more to help diagnose the problem.
    Right now it could be anything..



  • @firefox:

    No one is has encountered a problem like this?

    Now in order to have access to the Internet
    Transparent proxy not Checked

    I also use squid and HVAP (as parent for squid) the same way you use them and do not have problems.



  • I have the same problem in sometime.

    If squid stop and can't start it. Try this

    1. Stop Havp and uncheck enable proxy in Havp Setting(Http Proxy menu)

    2. Check service status. Now squid will start.

    3. Check enable proxy in Havp Setting(Http Proxy menu) and start Havp service again.

    (if squid still down try same step)



  • Answer
    After searching online and especially here in the forums

    I saw that you can fix the problem if you delete and create squid libraries

    squid makes some problems if the computer not turn off normally

    ssh to your pfsense
    and use this

    squid -z