Snort crashes after upgrade to 2.0.3



  • Just fyi, snort was running fine without problems on 2.0.2 32 bit.  I upgraded within the webgui to 2.0.3 and snort wouldn't start. rolled back to 2.0.2 and snort worked fine.



  • I have the same issue.  Have not rolled back, but Snort is crashed.



  • @cdsJerry:

    I have the same issue.  Have not rolled back, but Snort is crashed.

    Can you elaborate for me a bit on "crashed"?  First up what version of Snort did you have prior to the upgrade?  In other words, did Snort get auto-upgraded as part of the 2.0.3 upgrade?  Do you see any errors in the system log?  If so, can you post back with any of them?  I assume you have tried to start Snort manually after the upgrade.  Do any errors get logged then?

    As part of the testing I did for 2.5.6, I tried a number of upgrade scenarios and did not stumble upon this problem.

    UPDATE:  one other thing occurred to me – have you tried deleting the Snort package from Installed Packages and then re-installing again from Available Packages?   There were some issues with the older Snort and installation of the newer Snort where some binary dependencies did not get properly cleaned up.  Deleting the Snort package completely and then reinstalling helped in these cases.  Improving this reinstall and upgrade process was one of the fixes in the later package, but if you are coming from a much older version, then you can have some issues without doing the delete.

    Post back with some of the info I asked for, and I will be glad to help out.

    Bill



  • Downloaded the snort rules again then restarted the service.  It appears to be happy now, which makes me happy.



  • @cdsJerry:

    Downloaded the snort rules again then restarted the service.  It appears to be happy now, which makes me happy.

    Good.  I have submitted an update to 2.5.7 for Snort.  The pfSense team is reviewing it.  One of the fixes in the new update was for issues with automatic rule updates, particularly following upgrades where the Snort package itself gets reinstalled as part of the pfSense upgrade.

    If the team approves the update, it will show up in Installed Packages as an update to 2.5.7.

    Bill



  • I had rolled back to 2.0.2 since snort kept failing to start after the 2.0.3 upgrade about a week and a half ago.  I tried uninstalling then installing snort again after the upgrade with the same result.  I upgraded today to 2.0.3 and everything appears to work even after a rules update and restart.  Must have been something on my end since the 2.0.3 hasn't changed since it's initial release.  Thanks for your help.



  • There are 0 changes in the package system between 2.0.2 and 2.0.3, any problems you have with packages on 2.0.3 are the same on 2.0.2.

    The Snort update bmeeks made was merged a few days ago, which I believe was the resolution of the issues here.


Log in to reply