Squidguard não loga os acessos



  • Pessoal,

    Estou com a versão 2.0.3 do pfsense.. instalei o squidguard, depois o squid3.. os serviços estão iniciados..
    Porem o squidguard não está logando.. ja reinistei, instalei.. refiz as configurações e nada.. ele não loga

    Em real time do squid.. os usuarios estão passando pelo squid.. porem não mostra nada no squidguard..

    Repito, os serviços estão iniciado…

    | Blocked | Filter GUI log | Filter log | Proxy config | Filter config |
    No data.
    

    O arquivo esta zerado.

    
    0 -rwxr-xr-x  1 proxy  proxy      0 Apr 21 07:22 block.log
    92 -rwxr-xr-x  1 proxy  proxy  92290 Apr 21 08:17 sg_configurator.log
    88 -rwxr-xr-x  1 proxy  proxy  88272 Apr 21 08:27 squidGuard.log
    
    

    os pacotes

    squid-2.7.9_3       HTTP Caching Proxy
    squid-3.1.20        HTTP Caching Proxy
    squidGuard-1.4_4    A fast redirector for squid
    

    Porta do proxy: 8080

    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;redirector_bypass off;url_rewrite_children 5
    

    Alguem sabe o problema ?



  • Enable log esta marcada na aba general settings?

    Edit: De qualquer forma, no realtime do squid você vê os bloqueios.



  • está habilitado..

    o interessante que a versão 2.0.2 que tenho em outro cliente não tem esse problema..



  • Olá!

    Só para efeitos de teste, remova os dois pacotes e limpe os arquivos de LOG que ficam no PFSense em "/var/squid/log".
    Instale o Squid3, depois o Squidguard.
    Lembre-se, é necessário marcar para fazer LOG tanto no Squid quanto no SquidGuard.



  • Ja fiz de tudo, reinstalei diversas vezes.. e não tem jeito..

    Apr 23 23:52:17	squid[38283]: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept
    Apr 23 23:52:17	check_reload_status: Reloading filter
    Apr 23 23:52:19	php: /pkg_mgr_install.php: Starting Squid
    Apr 23 23:52:19	squid[55576]: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept
    Apr 23 23:52:19	php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -f /usr/local/etc/squid/squid.conf' returned exit code '1', the output was 'FATAL: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept Squid Cache (Version 2.7.STABLE9): Terminated abnormally.'
    Apr 23 23:52:20	php: : SQUID is installed but not started. Not installing "nat" rules.
    Apr 23 23:52:20	php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 23 23:52:21	php: : SQUID is installed but not started. Not installing "filter" rules.
    Apr 23 23:52:23	Squid_Alarm[11818]: Squid has exited. Reconfiguring filter.
    Apr 23 23:52:23	Squid_Alarm[12212]: Attempting restart...
    Apr 23 23:52:23	squid[13041]: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept
    Apr 23 23:52:29	check_reload_status: Reloading filter
    Apr 23 23:52:30	php: /pkg_mgr_install.php: Starting Squid
    Apr 23 23:52:30	squid[16708]: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept
    Apr 23 23:52:30	php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -f /usr/local/etc/squid/squid.conf' returned exit code '1', the output was 'FATAL: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept Squid Cache (Version 2.7.STABLE9): Terminated abnormally.'
    Apr 23 23:52:32	php: : SQUID is installed but not started. Not installing "nat" rules.
    Apr 23 23:52:33	php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 23 23:52:33	php: : SQUID is installed but not started. Not installing "filter" rules.
    Apr 23 23:52:41	check_reload_status: Reloading filter
    Apr 23 23:52:41	check_reload_status: Syncing firewall
    Apr 23 23:52:43	php: : SQUID is installed but not started. Not installing "nat" rules.
    Apr 23 23:52:44	php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 23 23:52:44	php: : SQUID is installed but not started. Not installing "filter" rules
    


  • 
    Apr 23 23:52:30	squid[16708]: Bungled squid.conf line 4: http_port 127.0.0.1:3128 intercept
    
    

    Você tem um problema na configuração do Squid.

    Duas soluções:

    1 - Remova o pacote completamente, excluindo pelo Shell e depois as pastas que sobrarem no disco.

    2 - Backup e formatação no Servidor.



  • Estou com esse mesmo problema do colega

    ja apague os seguintes diretorios

    var/log/squid
    var/log/squidGuard
    var/db/squidGuard
    var/squid
    usr/local/squid
    usr/local/squidGuard
    
    

    porem quando eu instalo novalmente as configurações estão salvas..

    faltou algum diretorio ?



  • @thiagomespb:

    porem quando eu instalo novalmente as configurações estão salvas..

    faltou algum diretorio ?

    Falta a configuração do xml. os arquivos de configuração são gerados pelo script que lê do xml e cria os arquivos.

    Com muito cuidado, você pode excluir as configurações do squidguard no xml usando o comando viconfig.

    Tenha em mente que qualquer erro neste procedimento, você pode acabar com seu pfsense.

    Não esqueça do backup.



  • onde fica esse .xml do squidguard ?



  • @gst.freitas:

    onde fica esse .xml do squidguard ?

    O xml do pfsense é um só.

    faça o backup via gui. o diretório onde ele fica é /conf

    para editar, como postei anteriormente, usamos o viconfig.

    att,
    Marcello Coutinho


Log in to reply