Iftop duvida…



  • não e recomendado instalar o iftop no PFSENSE pois pode abrir brechas no firewall, isso é verdade ?alguem pode tirar essa minha duvida…

    desde já agradeço



  • @ignti:

    não e recomendado instalar o iftop no PFSENSE pois pode abrir brechas no firewall, isso é verdade ?alguem pode tirar essa minha duvida…

    Onde você leu isso?

    Até onde sei o iftop é um binário, não um daemon que abre uma porta.



  • @marcelloc:

    @ignti:

    não e recomendado instalar o iftop no PFSENSE pois pode abrir brechas no firewall, isso é verdade ?alguem pode tirar essa minha duvida…

    Onde você leu isso?

    Até onde sei o iftop é um binário, não um daemon que abre uma porta.

    Não Marcelloc li num blog , mas, como vc mesmo falou ele é um binário e foi esse meu susto quando vi esse comentário, mas enfim queria mesmo tirar esta dúvida.

    Obrigado ai pelo esclarecimento..



  • @marcelloc:

    @ignti:

    não e recomendado instalar o iftop no PFSENSE pois pode abrir brechas no firewall, isso é verdade ?alguem pode tirar essa minha duvida…

    Onde você leu isso?

    Até onde sei o iftop é um binário, não um daemon que abre uma porta.

    bom Marcelloc,

    tentei instalar o IFTOP , porém apresentou os seguintes problemas:

    eu executei o comando : pkg_add -r http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/iftop.tbz
    porém não funcionou, quando digitei no shell: iftop apresentou a seguinte mensagem veja no print abaixo:

    ![Sem título.jpg](/public/imported_attachments/1/Sem título.jpg)
    ![Sem título.jpg_thumb](/public/imported_attachments/1/Sem título.jpg_thumb)



  • Instala a libpcap também, ou verifica se existe outra versão já no sistema com o comando find / -name "libpcap*"



  • @marcelloc:

    Instala a libpcap também, ou verifica se existe outra versão já no sistema com o comando find / -name "libpcap*"

    Dei o comando o :find / -name "libpcap*" veja no print abaixo o que me mostrou em tela. o que fazer agora?… :'(




  • Você tem uma versão mais nova da libpcap.

    Suas alternativas são:

    • instalar uma versão mais nova do iftop

    • criar um link simbólico do /lib/libpcap.so.7 usando o comando ln -s /lib/libpcap.so.7 /lib/libpcap.so.5


  • Administrator

    @marcelloc:

    Você tem uma versão mais nova da libpcap.

    Suas alternativas são:

    • instalar uma versão mais nova do iftop

    • criar um link simbólico do /lib/libpcap.so.7 usando o comando ln -s /lib/libpcap.so.7 /lib/libpcap.so.5

    Se a lib mudou de versão, significa que a API/ABI foi alterada, criar um link simbólico é arriscado na minha opinião. O ideal seria você pegar uma versão mais nova do iftop, que tenha sido linkada com a libpcap.so.7.

    Ah, e o iftop está disponível para instalação através do System -> Packages nos snapshots do pfSense 2.1, no futuro vai ser mais simples pra você instalar ele.



  • Humm… ok, Renato.

    isso que estava pensando pegar uma versão adequada, mas, a questão qual? ou melhor existe já alguma? se souber por favor me ajuda aê...mas mesmo assim muito obrigado


  • Administrator

    @ignti:

    Humm… ok, Renato.

    isso que estava pensando pegar uma versão adequada, mas, a questão qual? ou melhor existe já alguma? se souber por favor me ajuda aê...mas mesmo assim muito obrigado

    Não sei não, tenta pegar o do Free 8.3 e vê no que dá.


Log in to reply