Pfsense stops all traffic for no known reason



  • Hello everyone
    i run pfsense 2.0.3 on ibm x336 - 2X dual core / 4GB ram / 2x136GB iscsi (raid1 hardware)
    i have 2 of those working in master and backup in carp
    before adding the carp and also after -
    at specific times of day pfsense stops forwarding traffic to and from the servers behind it
    (i use many public ips as i host many websites and vps's) and everything just stops
    i can log in to pfsense from inside or outside the network with no issues, it seems all public ips stop responding (i work with nat, not transparent firewall), i can resolve this by restarting the lan (ifconfig bge0 down - ifconfig bge0 up) but it fails again a few times before staying on for about 20 hours, and then again, this has been going on for a while now - cold/hard reset doesn't solve this also
    packages i use: snort, pfblocker

    things from logs:
    Error while feeding rrdtool: Broken pipe
    /usr/local/bin/rrdtool respawning too fast, waiting 300s

    nothing else
    appreciate any help



  • one more thing
    i use static address as gateway - no PPOE or DHCP involved here


  • Netgate Administrator

    That logged error is normal and nothing to worry about.

    Since you're using Broadcom NICs you should probably try this first:
    http://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#Broadcom_bge.284.29_Cards

    Steve



  • I will try
    thanks a lot for this life-saving answer (assuming it will resolve the issue) :)



  • :-[ - the solution above seemed to have improve the situtation by far
    however this morning it happened again, all nat was dropped until i restarted bge0

    anyone else has seen this?

    any help would be appreciated



  • now its even worse
    it works for less than a minute after bge0 restart and falls back again



  • replaced broadcom onboard with pcix nic (intel em)
    i will update in a week or so if problem is solved now


  • Netgate Administrator

    Hmm, interesting. What changes did you make exactly that initially seemed to help?

    Steve



  • Hey Steve
    i have added the lines exactly as they are shown on the tutorial you directed me to
    it seemed to last for 48 hours before failing again

    so i have added the intel nic boot loader settings as well, (i have previously added an intel network card with 2 nic)
    and i have changed this:
    WAN BGE1
    SYNC EM1
    LAN BGE0

    to this:
    WAN BGE1
    SYNC EM1
    LAN EM0

    so far so good (been a few days)

    thanks a lot for the help!! i hope i have seen the pfsense fail for the last time  :)


  • Netgate Administrator

    Good to hear.  :)
    I only asked because other users have reportedly done that and ended up misinterpreting the instructions etc.

    Steve


Log in to reply