Installation 2.0.3 i386 hang up at 38%



  • I'm a newbie here, before going any further, thank a lot to whom will pay attention to my subject

    I'm installing pfsense 2.0.3 i386,  and it hangs at 36% with the message:
    /usr/local/bin/cpdup -vvv -I -o /usr /mnt/usr

    this problem was discused in
    http://forum.pfsense.org/index.php/topic,31907.0.html
    but it seems that there was not a good solution for others, neither for me,  I tried them all.

    My configuration:
    Motherboard: ASUS p8c-ws,  Intel Core i5,  8 Gb RAM ,  1.8 T RAID 5(3x1Tb)

    I found also a Issue Demand here:  http://redmine.pfsense.org/issues/2945
    it is the same problem

    Is there someone having the same problem?



  • By viewing the log file,  I found that there are other error:
    /usr/local/bin/cpdup -vvv -I -o /sys /mnt/sys
    Exit status:  1



  • And now,  under pression of my boss, I need to make it functionnal,  so I installed this version:
    pfsens 2.0 RC1-I386 ver 20110226-1530
    on the same machine,  and there is  no more waiting at 36% ….
    but,  it said:  Root mount failed, startup aborted at the first boot up

    I tried serveral things  and I found that the Slice used by pfsense 2.0 Rc1 should be smaller than 1 Tb,  if not,  there will be a message "root mount failed"



  • Yep, I'm having the same issue too

    I'm using a Dell PowerEdge 2950… 4GB RAM, PERC RAID, etc..

    This server was originally installed with 2.0.1-RELEASE (i386) and has been successfully upgraded to 2.0.3-RELEASE (i386) without any problems.

    However, I came in to the office today and noticed a hard-drive had failed, so I thought I'd better replace it… long story short, I'm now trying to re-install 2.0.3-RELEASE (i386) from scratch :)

    I'm booting / installing from a USB stick using pfSense-memstick-2.0.3-RELEASE-i386-20130412-1022.img

    So... imagine my surprise, when trying to install the same release that was running before, doesn't seem to work any more.

    I've tried most of the reported attempts, ie remove all network cables, turn off virtualisation in the CPU, etc, but nothing appears to help. Of course, this appears to suggest that it's a hardware detection issue somewhere, but there's not much error logging to help diagnose this...

    I was using RAID5, then I tried RAID1 (with HotSpare), but that didn't seem to change anything.
    I tried making the root partition 4G, but that didn't make any difference either.
    I tried using default and changed keymaps too (yep, getting desperate :))

    I've now run out of time, so I'm currently restoring a backup I made before starting this adventure (luckily I have a spare drive! ;))

    One thing I hadn't tried, was letting the USB stick boot all the way through, past the choice to (I)nstall or (C)ontinue... maybe from there the hardware is recognised differently?

    Either that, or I could try re-installing 2.0.1 and upgrading all the way again... bit silly though...



  • Just experienced this as well on 2 totally different machines.

    Took a while but by turning off virtualization, disabling multicore and any other cpu features for saving power , installing with ethernet cables unplugged and unplugging the usb keyboard right after it starts installing pfSense to the hard drive, only then have I managed to get it to install without stopping at 36%.  Seems one specific setting is not the key but all of them combined.



  • @AhnHEL:

    Took a while but by turning off virtualization, disabling multicore and any other cpu features for saving power […]

    Had the same problem year ago and it was on of this options in the bios.
    Cost me a full day to find that out  :-[



  • Hi my friends,  sorry for respons late,  I was illed…. 
    Yes,  finally,  I used 2.0 RC3 AMD64 ,  and there is really a limit of disk capacity,  it should be less than 1 TB
    Thanks again



  • Can i also add pfsense works amazing on VMware. And as a virtual machine you can chop the 1tb down and its amazing!


Locked