DNS Forwarder forwards all queries



  • As of the latest two snapshots, the DNS forwarder is forwarding everything.  It is not returning any locally configured overrides or dhcp reservations.

    I did verify that  "Register DHCP static mappings in DNS forwarder" is checked.

    I have reverted to Apr 30 as that was the latest backup I had.

    If I can provide any more information, please let me know.



  • I have updated 1 system to 2.1-BETA1 (i386) built on Sun May 5 07:29:11 EDT 2013
    In DNS Forwarder I have the following:
    Register DHCP leases in DNS forwarder - checked
    Register DHCP static mappings in DNS forwarder - checked
    Require domain - checked
    Do not forward private reverse lookups - checked
    A handful of Host Overrides including some aliases.
    Domain overrides that send queries for various internal namespaces across OpenVPN links to internal DNS servers.

    It all seems to be working - /etc/hosts has lots of stuff in it and I can resolve names that are in the Host Overrides section and names that are from DNS servers across OpenVPN links, and names out in internet-land.

    If you still have a problem, post detail of your DNS Forwarder settings.



  • @mikepell:

    As of the latest two snapshots, the DNS forwarder is forwarding everything.  It is not returning any locally configured overrides or dhcp reservations.

    I did verify that  "Register DHCP static mappings in DNS forwarder" is checked.

    I have reverted to Apr 30 as that was the latest backup I had.

    If I can provide any more information, please let me know.

    Yesterday I had the same problem. I went back to the backup snapshot, where it worked, and then updated the firmware is up to the latter. Now it works.



  • I have the same problem and i've the last build of pfsense 2.1 (but on amd64) and the same  configiguration as you stated by Phil : static leases don't work.
    I see one dynamic lease in /etc/hosts, no static lease. If i manualy update /etc/hosts and put information for a static lease, then it works (but that's not a solution beacause it go away when /etc/hosts got regenerated).

    EDIT : sorry i've not seen the other post about it (but i 've a build 2.1-BETA1 (amd64)
    built on Thu May 2 17:27:55 EDT 2013
    FreeBSD 8.3-RELEASE-p8)
    and the dashboard says "You are on the latest version." ==> i will apply the patch by hands…



  • I can confirm, static entries don't work on "2.1-BETA1 (i386) built on Sun May 5 07:29:51 EDT 2013", particularly, I have "Resolve DHCP mappings first" unchecked, as I need to override a DHCP lease with a common name (VMs)



  • I can confirm it is working properly in 2.1-BETA1 (i386) built on Sun May 5 07:29:51 EDT 2013.

    It definitely did not work when I updated to the May 4 snapshot.

    Also, sorry I missed the other posting on this somehow.



  • Applying the patch by hands on the last amd64 version worked fine…


Log in to reply