Wireless standard went missing



  • When I first set up pfsense, my wireless nic had three options for wireless standard.
    -b
    -g
    -gn

    When I look now, gn is missing from that list.
    Anyone know what might have happened?

    It's an Atheros nic, I'm certain of the exact model, but I do know it supports n.



  • the card may support it, but freebsd doesn't.
    see wiki: http://doc.pfsense.org/index.php/Is_802.11n_wireless_supported

    my 2 cents: get an AP if you want or need "n" performance.



  • @bennyc:

    the card may support it, but freebsd doesn't.
    see wiki: http://doc.pfsense.org/index.php/Is_802.11n_wireless_supported

    my 2 cents: get an AP if you want or need "n" performance.

    You misunderstand.
    The option was there a day ago.



  • It might very well be I'm not understanding you, but I doubt you'll get it working in 'N'.
    See also thread http://forum.pfsense.org/index.php/topic,61948.0.html with an interesting post from stephenw10 (reply #5)



  • @bennyc:

    It might very well be I'm not understanding you, but I doubt you'll get it working in 'N'.
    See also thread http://forum.pfsense.org/index.php/topic,61948.0.html with an interesting post from stephenw10 (reply #5)

    Yes, I know N will probably not work.  I'm asking why, ng mode was listed in the options when I set up the machine, but now it's missing.
    I am running on G mode anyway.


  • Netgate Administrator

    Does seem odd. Have you changed anything else? Updated pfSense? Can you find out which model/chipset?

    You can find out what it is without removing it. E.g.

    [2.0.3-RELEASE][root@pfsense.fire.box]/root(4): sysctl dev.ath
    dev.ath.0.%desc: Atheros 2413
    dev.ath.0.%driver: ath
    dev.ath.0.%location: slot=6 function=0
    dev.ath.0.%pnpinfo: vendor=0x168c device=0x001a subvendor=0x144f subdevice=0x7094 class=0x020000
    dev.ath.0.%parent: pci4
    dev.ath.0.smoothing_rate: 95
    dev.ath.0.sample_rate: 10
    dev.ath.0.sample_stats: 0
    dev.ath.0.countrycode: 0
    dev.ath.0.regdomain: 100
    dev.ath.0.slottime: 9
    dev.ath.0.acktimeout: 48
    dev.ath.0.ctstimeout: 48
    dev.ath.0.softled: 0
    dev.ath.0.ledpin: 0
    dev.ath.0.ledon: 0
    dev.ath.0.ledidle: 270
    dev.ath.0.txantenna: 1
    dev.ath.0.rxantenna: 1
    dev.ath.0.diversity: 0
    dev.ath.0.txintrperiod: 5
    dev.ath.0.diag: 0
    dev.ath.0.tpscale: 0
    dev.ath.0.tpc: 0
    dev.ath.0.tpack: 63
    dev.ath.0.tpcts: 63
    dev.ath.0.rfsilent: 1
    dev.ath.0.rfkill: 1
    dev.ath.0.intmit: 1
    dev.ath.0.monpass: 24
    
    

    Steve



  • one thing that comes to mind: did you by any chance set WEP encryption for that interface?

    br, Benny


Log in to reply