2.0.1 to 2.1 upgrade fail



  • I was running 2.0.1 and I used the WebUI to upload "pfSense-Full-Update-2.1-BETA1-amd64-20130506-1654.tgz" the WebUI gave me a nice spinning disk upgrade graphic for over an hour before finally just giving me this:

    Fatal error: Call to undefined function pfSense_interface_listget() in /etc/inc/interfaces.inc on line 66

    (just that error on an otherwise blank page)
    I'm still connected to the internet, so it's not a complete fail, but I'm hesitant to reboot the pfsense server. perhaps I should download a 2.0.3 ISO before I reboot.

    I wanted to start testing IPv6 @ home, so what's my best option? Perhaps a clean install of 2.1 rather than an upgrade?



  • You change architectures in the process? Sounds like maybe what would happen if going i386->amd64.



  • ;D I don't remember. I was pretty sure I was running amd64, but it's been running so long without fail or need of management, so I've become blissfully ignorant of my own setup.



  • If you did, just power cycling should get you back to a functional and upgraded system. Problem when you switch architectures is at the end it can't run the different architecture's reboot binary so you're stuck until you power cycle it. That's assuming it's a 64 bit capable CPU, if not you're going to be sunk after power cycling it. Have ISOs and config backup ready to reinstall if needed, and power cycle it.



  • Had the same thought. After a hard power-cycle it's up and running 2.1 and now the only issue is the avahi package wouldn't run. Looks like I was indeed running i386 before. I think had trouble initially installing the AMD64 version of 2.0 on this old intel P4

    Thanks for the assist.


Log in to reply