SquidGuard blocking pages



  • Hi,
        I'm experiencing a problem with squidGuard, if I block a site and access it, it is blocked as expected, but if I allow it and try to access again, it will not open, still giving me the block page until the browser cache is cleared.
        Another thing is that it interfere with local sites, blocking pages even if I check the option on IE to do not use proxy for local network, a strange behavior since squid alone don't do this.
        I'm using squidGuard version 1.4_4 pkg v.1.9.3 and pfSense 2.0.3.

    Thanks!



  • Make sure you didn't put it under "whitelist" just use "…." from the drop down!
    And check default access [all] = "allow"!



  • @kelsen:

    I'm experiencing a problem with squidGuard, if I block a site and access it, it is blocked as expected, but if I allow it and try to access again, it will not open, still giving me the block page until the browser cache is cleared.

    By definition, that's what a browser cache is - a local cache in your web browser. Reload a few times or "shift-reload" in most browsers should change the page. SquidGuard isn't doing that blocking, it was ALREADY blocked and the browser cached it (the block page) locally.



  • @srk3461:

    Make sure you didn't put it under "whitelist" just use "…." from the drop down!
    And check default access [all] = "allow"!

    I've done that, still the cache of browser showing the block page.

    @markuhde:

    By definition, that's what a browser cache is - a local cache in your web browser. Reload a few times or "shift-reload" in most browsers should change the page. SquidGuard isn't doing that blocking, it was ALREADY blocked and the browser cached it (the block page) locally.

    Yep, but even if I pass the eternity reloading the page it won't work, as I said, squid alone won't do this, if I reload after allow a site that was blocked, it work.
    Surely no one is having the same problem with squidGuard?



  • Nope no problem here with squidguard like that!
    why dont you give this a read -> http://forum.pfsense.org/index.php/topic,62001.0.html



  • @srk3461:

    Nope no problem here with squidguard like that!
    why dont you give this a read -> http://forum.pfsense.org/index.php/topic,62001.0.html

    By all means, he delete the browser's cache, and I could do that, but this is complicated in a new environment because everytime I allow a page that was blocked, I have to clear the cache.
    I'm curious why you or anyone isn't having the same problem, because every squidGuard installation do the same thing; could you simulate it? block a page, open it, then allow and reload the page without clearing the cache?
    thanks!



  • Yep, I did test it and i could reload the page without clearing the cache on both browser I use i.e chrome, firefox.
    Looks like something wrong with your browser settings,

    Have you set you browser to "never remember history" or something like that!? (Just A Hunch)



  • Actually firefox is configured to remember everything.


Log in to reply