SARG 2.3.6 pkg v.0.6.1 - Graph issue



  • Since the 2.3.6 update, I no longer have access to the graphs in my SARG reports. No png files are created in the report directory.
    When I run sarg in the ssh console, here's the output :

    /usr/local/sarg-reports(48): sarg
    SARG: (info) No graphs available as sarg was not compiled with libgd. Set "graphs" to "no" in /usr/local/etc/sarg/sarg.conf to disable this warning
    SARG: Records in file: 45820, reading: 100.00%
    SARG: Successful report generated on /usr/local/sarg-reports/01May2013-07May2013

    Was it planned that graphing would no longer be supported in SARG ?



  • What pfsense version are you using?



  • 2.0.3-RELEASE (i386)
    built on Fri Apr 12 10:22:21 EDT 2013
    FreeBSD 8.1-RELEASE-p13



  • got this too:

    May 9 10:17:43 kernel: pid 39732 (sarg), uid 0: exited on signal 11 (core dumped)

    May 9 10:17:43 php: /pkg_edit.php: The command '/usr/local/bin/sarg -d date +%d/%m/%Y-date +%d/%m/%Y' returned exit code '139', the output was 'SARG: (info) No graphs available as sarg was not compiled with libgd. Set "graphs" to "no" in /usr/local/etc/sarg/sarg.conf to disable this warning SARG: Records in file: 6, reading: 0.00%^MSARG: Period covered by log files: 09/05/2013-09/05/2013'

    setting graphs to no gives:

    May 9 10:23:06 kernel: pid 5480 (sarg), uid 0: exited on signal 11 (core dumped)

    May 9 10:23:06 php: /pkg_edit.php: The command '/usr/local/bin/sarg -d date +%d/%m/%Y-date +%d/%m/%Y' returned exit code '139', the output was 'SARG: Records in file: 1, reading: 0.00%^MSARG: Period covered by log files: 09/05/2013-09/05/2013'

    2.0.3-RELEASE (amd64)
    built on Fri Apr 12 10:27:56 EDT 2013
    FreeBSD 8.1-RELEASE-p13
    dansguardian 2.12.0.3 pkg v.0.1.8
    squid 3.1.20 pkg 2.0.6
    sarg 2.3.6 pkg v.0.6.1



  • Unselect first option on sarg option(use graphics) and try again.



  • @Hugovsky:

    setting graphs to no gives:

    May 9 10:23:06 kernel: pid 5480 (sarg), uid 0: exited on signal 11 (core dumped)

    May 9 10:23:06 php: /pkg_edit.php: The command '/usr/local/bin/sarg -d date +%d/%m/%Y-date +%d/%m/%Y' returned exit code '139', the output was 'SARG: Records in file: 1, reading: 0.00%^MSARG: Period covered by log files: 09/05/2013-09/05/2013'

    2.0.3-RELEASE (amd64)
    built on Fri Apr 12 10:27:56 EDT 2013
    FreeBSD 8.1-RELEASE-p13
    dansguardian 2.12.0.3 pkg v.0.1.8
    squid 3.1.20 pkg 2.0.6
    sarg 2.3.6 pkg v.0.6.1

    I did. Sorry for being somewhat not related to this topic.



  • After manually uninstalling SARG 2.3.6 and reinstalling sarg-2.3.2_5  in the ssh console, the graphing feature is available again. It seems the 2.3.6 compilation didn't include the graphing feature.



  • Seems my problem was related to date format. Changed from European and sarg is working again.


Locked