HAVP not running



  • They say a picture is worth a thousand words.

    I can click the Start button for the Proxy, and it will start for a minute. But it doesn't stay running. I can click the Start Scanner button, and nothing happens. What confuses me the most is the Scanner status of "Not Found"

    I'm fairly new to pfsense so I'm having a bit of trouble troubleshooting this.



  • Looks like havp is broken with current pfsense - same behavior here after upgrading from 2.0.2 to 2.0.3



  • @adlerweb:

    Looks like havp is broken with current pfsense - same behavior here after upgrading from 2.0.2 to 2.0.3

    :o dumdumdummm



  • before we go to far down this path…  does anyone have HAVP running, correctly, under 2.0.3?

    Rick



  • Yes.

    Unistall havp through the gui.

    go to the command like type pkg_info

    Make sure havp does not show as an installed package.  If it is type pkg_delete -f "package_name"

    Reboot your box and go to the gui and reinstall and it should work.



  • We have a different problem, but it may be related to this? It seems as if our HAVP is running, but it doesn't take some of the configuration options into account. For example, it doesn't matter if I uncheck "Scan Broken Executables", it'll still throw all kinds of errors and false positives. My workaround so far has been to add sites to the whitelist, which does seem to be taken into account.

    Also, alerts are never shown in the web interface, but they do show up in the logs.

    We're running HAVP and Squid in HTTP transparent proxy mode.

    Does anybody have any idea how to tackle this? Right now we're running 2.0.2-RELEASE; I have to wait for some downtime to be able to upgrade.



  • @mschiek01:

    Yes.

    Unistall havp through the gui.

    go to the command like type pkg_info

    Make sure havp does not show as an installed package.  If it is type pkg_delete -f "package_name"

    Reboot your box and go to the gui and reinstall and it should work.

    I will do this when I find time. In the next day or so.



  • I had this same exact problem for weeks and nearly decided to scrap the product out of frustration. Then I did a swapinfo -h and saw that my swap space was 100% utilized and only 2MB in size. Then I realized I had chosen the quick and easy install which doesn't ask any questions and lays out your entire partitions for you.

    I re-ran the install to disk option in the mode where you get to chose your own layout and made sure to check the swap space allocation and even raised it to 4096MB. I haven't had the problem since.

    Hope this helps someone out there.



  • @steve40:

    I had this same exact problem for weeks and nearly decided to scrap the product out of frustration. Then I did a swapinfo -h and saw that my swap space was 100% utilized and only 2MB in size. Then I realized I had chosen the quick and easy install which doesn't ask any questions and lays out your entire partitions for you.

    I re-ran the install to disk option in the mode where you get to chose your own layout and made sure to check the swap space allocation and even raised it to 4096MB. I haven't had the problem since.

    Hope this helps someone out there.

    Damn… I too did the simple install.


Log in to reply