FreeRadius2 not starting



  • guys i know that this has been covered before. i have read just about all i can but my issue is not as complicated as some of the other users. i basically have a new pfsense install, configured a few things to get it running and installed freeradius2 to authenticate.

    i have tried to reinstall the package but that didnt work. when i installed on freeradius, that worked fine and i was able to test it with a few test users. i need the functionality in freeradius2.



  • Please do not mix freeradius1 and freeradius2 on one machine. The configuration for both packages is NOT compatible.

    In general you install freeradius2 using the package manager and then you just have to configure a listening interface. Then the service should run. Sometimes it is neccessary that you go to the freeradius2 –> EAP page and just click "save" even if you do not use it.

    If it is still not working then please tell us what you mean with "not working".



  • by not working mean the services wont start. i did not install both versions at the same time. i uninstalled freeradius1 and installed freeradius2 with a reboot in between.

    i switched back to make sure i had the right configs and with radisus1 i can authenticate users and i can verify services are running. when i try to run freeradius2 the service does not start and when i try to authenticate i get the message "error sending request: no valid radius responses received".

    in the logs i see this

    May 9 08:24:43 php[35228]: /pkg_edit.php: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    May 9 08:24:43 php[35228]: /pkg_edit.php: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'



  • i forgot to mention that i tried your suggestion but service is still stopped



  • @hussam:

    i forgot to mention that i tried your suggestion but service is still stopped

    Service is probably running. You can probably see that on pfsense syslog if you enabled logging on freeradius settings.
    The error you posted is in most cases as described in this post:
    http://forum.pfsense.org/index.php?topic=55580.0



  • syslog is enabled. i had already seen that post but i confirmed the correct username and pass.

    UPDATE:
    i completly reset pfsense to factory defaults and installed freeradius2. i set the interface and client and still the service is stopped.

    i will try a full reinstall. at what point should i see radius service running?



  • Hi again,

    in general you just need to install freeradius2 from package manager and then configure an interface. After that the service should be running and you should see "Ready to process requests" on syslog.

    Are you running freeradius2 on a full install of pfsense or on nanobsd image?

    Further just for understanding:
    freeradius2 –> NAS/Clients contains the different switches, accesspoints or CaptivePortal. You must enter there the IP of the switch and the identically password. The error your posted on your last post about

    error sending request: no valid radius responses received
    

    is mostly the reason of a wrong password on NAS/Clients config or on the switch - or the wrong IP address entered in NAS/Clients.

    The default listening port for authentication requests is 1812 - if you do not know which interface you should use you can use  *  which means "all interfaces".

    This error:

    php[35228]: /pkg_edit.php: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    

    appears sometimes but it does not cause any problems in general.

    If freeradius is still not running then you to console and start freeradius in debug mode with:

    radiusd -X
    

    This will show you exactly what is worong, which modules could not be loaded or if it is just a misconfdiguration or bug of the NAS/Client. It would make sense to post this output here if you could not find the problem by yourself.



  • i am running 2.0.3-RELEASE (i386) FreeBSD 8.1-RELEASE-p13. the radius is on the same box as pfsense (
    ip 192.168.1.1) so that's the same ip i have on the interface and client. when i did the initial install with radius1, i had it working with the same configs and passwords. i just reloaded and box and will try again.

    i had a hard time installing it and burned different copies of the download thinking i had bad media. do you think if i had the nano version, freeradius2 wont work?

    i appreciate the help as i am a total noob with this.



  • Please run freeradius in debug mode and post the complete output.



  • i got it working now!!!!

    thanks fo your help :)



  • WTF, you got it working out of the blue? how did it work for you ? have you done anything? at least post what you did so any other people who had/have same problem can follow your solution  ??? ??? ??? ??? ???


Log in to reply