New 2.1 NAT settings



  • After updating to the 2.1 May 8 release, I've noticed that NAT reflection that I had for a server is no longer working.

    I have a domain setup at home so if I put in http://externalDomain.com/ it no longer works from inside the LAN. It works fine with https://internalhostname. I had the standard NAT reflection setup before with a NAT rule of 443 going to internal server 443. It looks like the rule now is NAT+proxy for reflection settings.

    Are there instructions on this new NAT+Proxy vs. Pure NAT? I suspect that if I chose NAT+Proxy I need to enable one of the advanced settings for NAT now. 1:1 NAT reflection, automatic outbound for NAT reflection, or NAT reflection mode for port forward. Right now they are all off.


  • Rebel Alliance Developer Netgate

    NAT+Proxy is the "classic" way of doing NAT reflection, which involves using netcat to bounce the connections back in, proxying the traffic.

    Pure NAT mode would require the other rules, because otherwise the source of the traffic is maintained and the server would respond back to the client directly, which breaks since the reply would come from the server's private IP and not the external IP expected by the client.



  • I ended up fixing this by just adding a DNS entry into the DNS forwarder. Thanks for the quick reply.


  • Rebel Alliance Developer Netgate

    That's the best way, avoid the reflection entirely :-)


Log in to reply