DansGuardian Error connecting to proxy



  • I have two sites running Squid (2.7.9 v4.3.3) and Dans Guardian (2.12.0.3 v.0.1)
    About every 10-15 minutes, the logs show:

    DansGuardian: [nnnnn] Error Connecting to Proxy.

    I've tried increasing the Proxy Timeout from 30 to 40s and this has not fixed the problem.

    Any ideas as to what is causing this error and how to resolve this?



  • Did you tried with squid3?



  • @neil:

    I have two sites running Squid (2.7.9 v4.3.3) and Dans Guardian (2.12.0.3 v.0.1)
    About every 10-15 minutes, the logs show:

    DansGuardian: [nnnnn] Error Connecting to Proxy.

    I've tried increasing the Proxy Timeout from 30 to 40s and this has not fixed the problem.

    Any ideas as to what is causing this error and how to resolve this?

    In your dans config - are you connecting to Squid running on the same box as dans (i.e. localhost:3128)?



  • Squid is running on the same server as Dans Guardian.
    To get Dans Guardian to work with Squid, I had to set the proxy IP to the IP
    address of the server, and set the proxy port to 3128 - localhost would not work.

    I have not tried Squid3 as I was not sure how to install this 
    Can I simply install Squid3, and in doing so will this "replace" the existing Squid
    and retain the configuration, or do I need to uninstall the current Squid and then
    install Squid3?

    thanks for your replies



  • @neil:

    Squid is running on the same server as Dans Guardian.
    To get Dans Guardian to work with Squid, I had to set the proxy IP to the IP
    address of the server, and set the proxy port to 3128 - localhost would not work.

    I have not tried Squid3 as I was not sure how to install this 
    Can I simply install Squid3, and in doing so will this "replace" the existing Squid
    and retain the configuration, or do I need to uninstall the current Squid and then
    install Squid3?

    thanks for your replies

    Localhost should work - I'm setup that way.

    I did not explicitly install squid2. It installs as part of Dansguardian. So… you can simply install Dans and then install Squid 3.



  • I have the same error (Dansguardian Error connecting to proxy) but I have many problems when surfing the internet.

    What would be the solution? …. Install squid3? (I have installed the squid2)

    I have problems Webupload also banned: (

    thanks

    My dansguardian 2.12.0.3 version is v0.1.8 and my squid is 2.7.9 pkg v.4.3.3



  • Run this to get rid of the Webupload issue. You need to do this every time you re-install Dansguardian.

    amd64
    fetch -o /usr/local/sbin/dansguardian "http://e-sac.siteseguro.ws/pfsense/8/amd64/dansguardian"

    i386
    fetch -o /usr/local/sbin/dansguardian "http://e-sac.siteseguro.ws/pfsense/8/dansguardian"



  • webupload problem solved, thanks asterisk.
    But I still have the problem of "Dansguardian [nnnn]: Error connecting to proxy".
    Someone who had this problem and I solve it?
    Parameters are configured in dansguardian? in the squid?

    : (



  • @ccarreraalza:

    webupload problem solved, thanks asterisk.
    But I still have the problem of "Dansguardian [nnnn]: Error connecting to proxy".
    Someone who had this problem and I solve it?
    Parameters are configured in dansguardian? in the squid?

    : (

    Nothing in squid cache.log ?
    Can you post the result of - when the problem occurs -

    netstat -n | grep WAIT | wc -l

    There latest version of DG fixes "Error connecting to proxy" but often this can hide a real problem, usually a bad tuning about system, for example with sysctl and the number of socket max, or perphaps local port range (squid + dg can eat more of them), I don't know about pfsense but I think you should see something in log, but not in DG's log.

    What about load average with top command ?



  • I have nothing in the cache.log

    "netstat-n | grep WAIT | wc-l"
    fluctuates between 60 and 180 approximately

    Average load TOP
    last pid: 58754, load averages: 0.00, 0.00, 0.00 up 5 +17:03:26 12:56:42
    180 Processes: 1 running, 179 sleeping
    CPU: 0.2% user, 0.0% nice, 0.0% system, 0.2% interrupt, 99.6% idle
    Mem: 365M Active, Inactive 651M, 152M Wired, 112M Buf, 823M Free
    Swap: 4096M Total, 4096M Free

    some parameters of my kernel

    kern.ipc.maxsockets: 25600
    kern.ipc.numopensockets: 591

    My network is 30 pcs and internet navigation sometimes is somewhat slow. I'm using WPAD correctly and smoothly

    dansguardian parameters

    Min / Max Children 8/120

    Min / Max Spare Children 8/64

    Children Prefork 10

    Max Age Children 500

    Max Ips 0


    It takes some values ​​more? .. or that issue should investigate?

    Thanks :)



  • And the bandwitch, full ? You can reduce squid timeout or increase dansguardian timeout beyond squid
    If you can, try a more recent release with more timeout parameters, I think you can find a package in marcelloc's posts



  • hello again, my problem persists, I have installed squid3 but does not solve the problem, I have the dansguardian 2.12.0.3 v0.18. How do I update dansguardian without losing data configuration and webconfig?



  • @ccarreraalza:

    hello again, my problem persists, I have installed squid3 but does not solve the problem, I have the dansguardian 2.12.0.3 v0.18. How do I update dansguardian without losing data configuration and webconfig?

    You can simply pull the DG executable out of the package you download from Marcelo's site.

    That said, I see no reason why a newer version would solve your problem. 2.12.0.3 DG should be able to connect to Squid and I highly suspect that something else is wrong with your configuration. Can you forget about DG for the moment, make sure squid is running stable and that you can stay connected to it? So… setup squid on the lan interface and manually connect to it as a proxy? Just trying to eliminate variables...


Log in to reply