Verizon UML290 not successfully starting ppp power on reset (hard boot)



  • I have had this working for over a year now but never with a connection established on power on boot.  I have to manually go under Status->Interfaces->WAN interface (ppp0) -> "Connect" to successfully make the ppp connection.  After the connection is established, all works fine.

    I have searched the pfsense forum and done web search for solutions.  I've tried to set /etc/defaults/rc.conf and /etc/ppp/ppp.conf to the following respectively in snippets below.  Short description is to set ppp_mode="ddial" in /etc/defaults/rc.conf and to set persist in /etc/ppp/ppp.conf.  I have seen the system boot up a couple of times with a power on boot in which the ppp connection was established.  Unfortunately, this is rare as that was after about 30 attempts in a single day.  I'm thinking at this point that somebody has already dealt with this power on connectivity issue.  Maybe the device is not ready at the point that the ppp connection is first attempted.  Any advice, suggestions, or solutions would be appreciated.

    /etc/defaults/rc.conf snippet (changes in bold underline
    –snip

    User ppp configuration.

    ppp_enable="YES"                # Start user-ppp (or NO).
    ppp_program="/usr/sbin/ppp"    # Path to user-ppp program.
    ppp_mode="ddial"                # Choice of "auto", "ddial", "direct" or "dedicated".

    For details see man page for ppp(8). Default is auto.

    ppp_nat="YES"          # Use PPP's internal network address translation or NO.
    ppp_profile="papchap"  # Which profile to use from /etc/ppp/ppp.conf.
    ppp_user="root"        # Which user to run ppp as

    Start multiple instances of ppp at boot time

    #ppp_profile="profile1 profile2 profile3"      # Which profiles to use
    #ppp_profile1_mode="ddial"      # Override ppp mode for profile1
    #ppp_profile2_nat="NO"          # Override nat mode for profile2

    profile3 uses default ppp_mode and ppp_nat

    –snip

    /etc/ppp/ppp.conf snippet (changes in bold underline)
    –snip
    default:
    set log Phase Chat LCP IPCP CCP tun command
    ident user-ppp VERSION

    Ensure that "device" references the correct serial port

    for your modem. (cuau0 = COM1, cuau1 = COM2)

    set device /dev/cuau1

    set persist
    set speed 115200
    set dial "ABORT BUSY ABORT NO\sCARRIER TIMEOUT 5
              "" AT OK-AT-OK ATE1Q0 OK \dATDT\T TIMEOUT 40 CONNECT"
    set timeout 180 # 3 minute idle timer (the default)
    enable dns # request DNS info (for resolv.conf)

    papchap:

    edit the next three lines and replace the items in caps with

    the values which have been assigned by your ISP.

    set phone PHONE_NUM
    set authname USERNAME
    set authkey PASSWORD

    set persist

    set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
    add default HISADDR # Add a (sticky) default route

    –snip

    pfsense Configuration:

    2.0.3-RELEASE (i386)
    built on Fri Apr 12 10:22:18 EDT 2013
    FreeBSD 8.1-RELEASE-p13

    Hardware:

    PCEngines alix2d13

    Thanks in advance
    -- Anthony


Log in to reply