PfSense shows same MAC for two devices



  • I have a number of computers connected to an 8 port switch.

    The issue involves two devices:
    Ooma (VoIP device for those unfamiliar), which gets DHCP assigned IP.
    PC which has static local IP configured.

    The problem.  In Diagnostic: ARP Table, column named MAC address, both of these devices show the same MAC! but different IP.
    When Ooma boots, pfSense is showing its proper MAC, which is different then the PC's.  But once Ooma completes booting, its MAC is changed to the one corresponding to the PC and Ooma's IP gets incremented by one, the next available DHCP address.

    I've notice an issue when my VNC session was getting dropped constantly when initiated from the PC.

    What I have changed recently.  I've changed all my network cabling to Cat6 from Cat5 (this past weekend).  I've installed a MiniPCI WiFi card into the pfSense laptop, so that I can have WiFi (old card did not run as AP under pfSense).  But WiFi is off (interface disabled).  I've also, about 1 week ago, updated pfSense to the newest version, from the previous one (at the same time as swapping WiFi).  I'm thinking that the pfSense update might have caused this.

    I've been using pfSense for a good month now without issue, that is prior to the above mentioned changes.

    I've tried rebooting pfSense, rebooting Ooma.

    Any ideas?

    Thanks



  • Solved.

    Turns out Ooma was spoofing my PC's address.  I'm not a networks expert, but it doesn't seem right to me to have this setting be the default.

    When changing out network cables, Ooma was disconnected from power for over 12hrs, I'm thinking the device reset itself to factory configuration.


Log in to reply