PfSense 2.1 BETA on ESXi 5.1



  • Had a very bad experience with 2.1 BETA on ESXi. Wanted to try get my network on IPv6 and also felt like testing out 2.1 as I had stopped using it for many months. Had a perfectly stable 2.0.3 VM system running since last few weeks. Not sure whats the issue with 2.1.. if its FreeBSD or maybe openvm tools issue. I couldn't get the 2.1 vmtools to install. It installed the .sh scripts but the drivers never installed. Had to use the 2.0 vm tools package. That could be it too.. not sure. Freshly installed base 2.1 VM crashes with no logs in just a matter of seconds the moment I start speedtest. I have 50/6 cable. Speedtest would start to show beautiful 49Mbps for like 2-3 secs and then the speed dial would start to fall rapidly. The system hangs with no response and the only way I could get it back up is to reboot it from the console by selecting option 5 through the VM console. If I do not touch it after reboot the system would totally crash after some time with no logs. Only way to get it back up is to reboot the VM instance.

    Has anyone successfully installed and worked with 2.1 BETA on ESXi ?


  • Banned

    I havent gone to 5.x yet in production since I dont feel comfortable with it. Lots of issues in Linux/freebsd environments and I dont have the time for that.

    Can you try to isolate the issue to pfsense/esxi by either go back to Vsphere 4.x or Pfsense 2.0.3??



  • Our test environment does not work at your network speeds - max 4MB download - but running very smoothly under 5.1 - snapshot in use is current as of time of this post - maybe stress related?

    Andrew


  • LAYER 8 Global Moderator

    I am running 2.1 beta

    2.1-BETA1 (i386)
    built on Fri May 10 16:28:23 EDT 2013
    FreeBSD 8.3-RELEASE-p8

    on esx 5.1, even using version 9 vm for pfsense.  And not sure what your talking about packages - there is a vm-tools package for 2.1

    It has been nothing but stable for me..  I have a 30/5 internet connection and get full speeds.  And my esxi host is nothing more than a HP N40L with a couple extra nics installed and 8GB of ram.




  • You have a different version of vmtools and you are on i386 version. Current 2.1 package is on 8.8.1 for the amd64 and I know its not a working package as I have tried it multiple times since last few days on multiple fresh pfSense installs. It does install on 2.0.3 but on the console it gives 2 errors (can't remember them) so I had kept the 2.0 vmtools version on it earlier.

    2.0.3 amd64 runs smoothly with no issues on the ESXi 5.1. I install the vmtools and then change the NICs to VXNET2 Enhanced and it works beautifully. I presume its vmtools package that is creating the instability for the 2.1 pfSense amd64. Since I can't install the 2.1 version (8.8.1) I can't test its stability.

    Can anyone check the RC version of VM Tools (8.8.1)?



  • @Supermule:

    Can you try to isolate the issue to pfsense/esxi by either go back to Vsphere 4.x or Pfsense 2.0.3??

    I have 2.0.3 amd4 on ESXi with 4GB RAM and it runs pretty good. Never have any issues.



  • @andrew0401:

    Our test environment does not work at your network speeds - max 4MB download - but running very smoothly under 5.1 - snapshot in use is current as of time of this post - maybe stress related?

    Andrew

    I don't think its stress related. Well one thing I do is I install the 2.0 version of vmtools and then change the NICs to vxnet2. I suppose that is causing the instability. Will move over to E1000 and see if that makes a difference.


  • LAYER 8 Global Moderator

    Never saw the need to run am64 on a vm, I sure am not giving it enough memory to make it a requirement.  Why not the vmxnet3, I tried running vmxnet3 - but ran into some issues with outbound vpn working.  Switched back to 1000 and works great, with my limited bandwidth and use not sure the 2 or 3 drivers would do much for me, etc.

    If you still having issues try the i386 install with the 1000 nics and the vmtools package listed and let us know how it turns out.



  • I have allocated 6GB RAM and require it as network activity goes up the roof on the weekends and since I have a lot of resource hungry packages 6GB is the sweet spot.
    I could never get vmxnet3 to load. If I install vmtools and change the NICS to vmxnet2 then the new NICs are detected but the drivers fail to detect vmxnet3. Tried many times. I have a dual gigabit Intel card.


  • LAYER 8 Global Moderator

    There are a couple of threads on the board getting vmxnet3 to load via the actual tools from vmware..  I had them running at one point on 2.1

    If I get a chance tonight I will try and duplicate you issues by installing the amd64 2.1 snapshot, etc.  Yeah if your needing 6gb then amd64 makes sense ;)

    Anyway you can breakout what your doing to other vms?  And not running all the packages via pfsense?  For example with ntop I just installed that on its own vm and run it when I need it.



  • Just have the base install with no packages except vmtools (for 2.0 version) .. 2.1 version vmtools package has an install issue. It says successfully installed the moment u click on the install link. No driver is loaded.


  • LAYER 8 Global Moderator

    Hmmm lets see if I can fire up a vm remotely..  I got an hour or so before, screw real work - this is more fun ;)

    edit: ok have it installed and booted.. Just put its wan into my lan, and its lan on a vswitch I am bringing up a vm on so I can hit the web gui.. Then I will try and install the tools.  But sofar so good.

    edit2: ok the open vm package installed just fine.. But its listed as 8.7 as well - so not sure what your saying is not working.  But I grabbed the latest amd64 snap pfSense-LiveCD-2.1-BETA1-amd64-20130514-1208.iso.gz

    Unzipped it, created 64bit freebsd vm, upgraded it to vm9..  And it seems to be working no problems.  Ran through the wizard, installed the vm package that was listed in the store 8.7.0.3046 (build-425873), and my vclient shows it running.

    Now I can leave this vm running if you want me to test it doing something?  But so far I was not able to duplicate your issues.  Im about ready to hit it for beer time.. So if I find time tonight or tmrw will try installing the vmxnet3 drivers.

    edit3:  And this was all through a openvpn connection to my home network, rdp to my home workstation then opening up vclient and then consoles for both the pfsense box and the vm that was on the lan side of the 2nd pfsense I brought up.  Who's wan I put in my normal lan network, so double natting currently.

    2.1-BETA1 (amd64)
    built on Tue May 14 12:09:39 EDT 2013
    FreeBSD 8.3-RELEASE-p8




  • This is what I see.. If you notice the 8.7 is for pfSense 2.0 and 8.8.1 is for 2.0/2.1 and is currently broken. Though I used 8.7.

    Open-VM-Tools Services Stable
    8.7.0.3046 (build-425873)
    platform: 2.0
    VMware Tools            Package info

    Open-VM-Tools-8.8.1 Services RC
    528969
    platform: 2.0
    2.1 VMware Tools Package info

    Right now I am testing on just E1000 and not vxnet2



  • Ok everything is stable on just E1000. Definite issue with vxnet2 drivers. Seems to be logical as the drivers are made for pfSense 2.0 and not 2.1

    For now I am not installing vmtools and will leave it at E1000 NICs

    Now if someone can fix the 2.1 vmtools package.


Log in to reply