Limite de Banda Através Proxy Autenticado



  • Olá pessoal.
    Estou efetuando alguns testes em VM's com o pfsense, onde encontrei uma situação que me deixou intrigado, segue o cenário.

    Possuo um link de 10 Mb, sendo 2 MB para upload. Com isso criei uma regra de Limiter no traffic Shapper, limitando a interface INTRA ( Lan VM's ) em 2 Mb para Download e 1 Mb para Upload.

    Quando utilizo proxy transparente, a regra é aplicada, onde faço download em média a 230 Kb/s, mas no proxy autenticado, o mesmo baixa com o link Full, 1.2 Mb de Download.

    Alguém saberia me dizer o porque isso ocorre ??



  • porque vc não utiliza delay_pool do squid?



  • No caso kelven, esse delay_pool é uma limitação através do próprio Proxy ??



  • Sim, da uma lida nesse material http://eriberto.pro.br/wiki/index.php?title=Implementação_de_delay_pool_com_Squid
    Já é um começo pra você intender e aprofundar.



  • interessante a sua dica.. mas como seria essa configuração no squid do pfsense.. vc já fez ?



  • Ainda não precisei fazer isso em nenhum dos meus clientes, por padrão já existe uma delay pool que pode ser configurada na aba Traffic mgmt com as opções Overall bandwidth throttling e Per-host throttling.
    Essas opções são bem limitadas e não sei se criando na mão no custom options vai sobrescrever a existente, teria que testar.



  • @jhonthan:

    Alguém saberia me dizer o porque isso ocorre ??

    Isso já passou algumas vezes aqui no fórum, mas vamos lá novamente.

    No traffic shape você limita o trafego que passa pelo firewall.
    Quando você usa proxy no proprio firewall, os pacotes param de passar por ele e passam a sair por ele.

    cliente -> proxy proxy-> internet
    Nesta configuração o trafego é gerado a partir do proprio firewall, via lo0 e não da lan para a wan como está configurado seu traffic shape.



  • Marcelloc

    No caso estou limitando através da regra de Lan In / Out. Onde através da Limiter do Traffic Shapper, criei a seguinte configuração:

    InLimite - 2Mb
    OutLimite - 1Mb

    Essa regra funciona no proxy transparente, mas no autenticado não funciona.
    Tentei criar a mesma regra no Floating, mas sem sucesso.


Locked